aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libghthash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libghthash/Makefile')
-rw-r--r--devel/libghthash/Makefile48
1 files changed, 20 insertions, 28 deletions
diff --git a/devel/libghthash/Makefile b/devel/libghthash/Makefile
index c63dbad2aead..914f45f26c01 100644
--- a/devel/libghthash/Makefile
+++ b/devel/libghthash/Makefile
@@ -3,49 +3,41 @@
PORTNAME= libghthash
PORTVERSION= 0.6.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www.ipd.bth.se/ska/sim_home/filer/
MAINTAINER= gahr@FreeBSD.org
COMMENT= Generic Hash Table
-USE_AUTOTOOLS= libtool
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+USES= libtool
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --datarootdir=${PREFIX}
USE_LDCONFIG= yes
PLIST_FILES= include/ght_hash_table.h \
lib/libghthash.a lib/libghthash.la \
- lib/libghthash.so lib/libghthash.so.2
-
-.if defined(.PARSEDIR)
-USE_GMAKE= yes
-.endif
-
-MAN3= ght_create.3 \
- ght_finalize.3 \
- ght_first.3 \
- ght_first_keysize.3 \
- ght_get.3 \
- ght_insert.3 \
- ght_next.3 \
- ght_next_keysize.3 \
- ght_remove.3
+ lib/libghthash.so lib/libghthash.so.1 \
+ lib/libghthash.so.1.1.0 \
+ man/man3/ght_create.3.gz \
+ man/man3/ght_finalize.3.gz \
+ man/man3/ght_first.3.gz \
+ man/man3/ght_first_keysize.3.gz \
+ man/man3/ght_get.3.gz \
+ man/man3/ght_insert.3.gz \
+ man/man3/ght_next.3.gz \
+ man/man3/ght_next_keysize.3.gz \
+ man/man3/ght_remove.3.gz
PORTDOCS= *
PORTEXAMPLES= *
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- (cd ${WRKSRC}/html && ${COPYTREE_SHARE} \* ${DOCSDIR})
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \*.c ${EXAMPLESDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/html && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \*.c ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>