aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libuv
diff options
context:
space:
mode:
Diffstat (limited to 'devel/libuv')
-rw-r--r--devel/libuv/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/libuv/Makefile b/devel/libuv/Makefile
index 68fad73ed285..afa3d2447b78 100644
--- a/devel/libuv/Makefile
+++ b/devel/libuv/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libuv
PORTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://libuv.org/dist/v${PORTVERSION}/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -18,12 +19,11 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
TEST_DEPENDS= gyp:${PORTSDIR}/devel/py-gyp-devel \
gmake:${PORTSDIR}/devel/gmake
-USE_AUTOTOOLS= aclocal automake autoconf libtoolize
-ACLOCAL_ARGS= -I m4
-AUTOMAKE_ARGS= -a -c -f
-USES= libtool pathfix pkgconfig
+USES= autoreconf libtool pathfix pkgconfig
+GNU_CONFIGURE= yes
PATHFIX_MAKEFILEIN= Makefile.am
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
pre-configure:
${ECHO_CMD} "m4_define([UV_EXTRA_AUTOMAKE_FLAGS], [ serial-tests])" \