aboutsummaryrefslogtreecommitdiffstats
path: root/devel/pecl-swoole/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/pecl-swoole/Makefile')
-rw-r--r--devel/pecl-swoole/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
index 6813d2b5f94c..38829bbea260 100644
--- a/devel/pecl-swoole/Makefile
+++ b/devel/pecl-swoole/Makefile
@@ -2,7 +2,8 @@
# $FreeBSD$
PORTNAME= swoole
-PORTVERSION= 1.8.13
+PORTVERSION= 1.9.5
+PORTREVISION= 1
CATEGORIES= devel net
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -14,15 +15,20 @@ COMMENT= Asynchronous & concurrent & distributed networking framework
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= php:ext ssl tar:tgz
+USES= execinfo php:ext ssl tar:tgz
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_PHP= pcre
-OPTIONS_DEFINE= HTTP2 REDIS
-HTTP2_LIB_DEPENDS= libnghttp2.so:www/nghttp2
+OPTIONS_DEFINE= HTTP2 REDIS RING_BUFFER SOCKETS
+HTTP2_LIB_DEPENDS= libnghttp2.so:www/libnghttp2
HTTP2_CONFIGURE_ON= --enable-http2 --enable-openssl
REDIS_LIB_DEPENDS= libhiredis.so:databases/hiredis
-REDIS_CONFIGURE_ON= --enable-async-redis --enable-coroutine
+REDIS_CONFIGURE_ON= --enable-async-redis
+RING_BUFFER_DESC= Use ring buffer pool
+RING_BUFFER_CONFIGURE_ON= --enable-ringbuffer
+SOCKETS_USE= PHP=sockets:build
+SOCKETS_DESC= Use native php sockets extension
+SOCKETS_CONFIGURE_ON= --enable-sockets
.include <bsd.port.mk>