aboutsummaryrefslogtreecommitdiffstats
path: root/devel/py-convertdate/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/py-convertdate/Makefile')
-rw-r--r--devel/py-convertdate/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/py-convertdate/Makefile b/devel/py-convertdate/Makefile
new file mode 100644
index 000000000000..8e11d92312cc
--- /dev/null
+++ b/devel/py-convertdate/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= convertdate
+PORTVERSION= 2.1.3
+PORTREVISION= 1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gmm@tutanota.com
+COMMENT= Converts between Gregorian dates and other calendar systems
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyephem>0:astro/pyephem@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR}
+
+NO_ARCH= yes
+
+post-patch:
+ ${RM} ${WRKSRC}/README.rst
+ ${TOUCH} ${WRKSRC}/README.rst
+
+.include <bsd.port.mk>