aboutsummaryrefslogtreecommitdiffstats
path: root/devel/qross/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qross/Makefile')
-rw-r--r--devel/qross/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/devel/qross/Makefile b/devel/qross/Makefile
index 675bd411b506..39570225dcac 100644
--- a/devel/qross/Makefile
+++ b/devel/qross/Makefile
@@ -13,7 +13,7 @@ LICENSE= LGPL20+
USES= cmake
USE_LDCONFIG= yes
-USE_QT4= designer gui network xml qmake_build uic_build moc_build \
+USE_QT4= corelib designer gui network xml qmake_build uic_build moc_build \
rcc_build script testlib
USE_GITHUB= yes
GH_ACCOUNT= 0xd34df00d
@@ -24,9 +24,9 @@ WRKSRC_SUBDIR= src
OPTIONS_DEFINE= PYTHON
OPTIONS_SUB= yes
PYTHON_DESC= Python bindings
-PYTHON_CMAKE_ON= -DENABLE_PYTHON:BOOL=true
-PYTHON_CMAKE_OFF= -DENABLE_PYTHON:BOOL=false
-PYTHON_BUILD_DEPENDS= sip:devel/py-sip
+PYTHON_CMAKE_BOOL= ENABLE_PYTHON
+PYTHON_BUILD_DEPENDS= ${PYTHON_INCLUDEDIR}/sip.h:devel/py-sip@${PY_FLAVOR}
+PYTHON_USES= python:2.7
OPTIONS_DEFAULT=PYTHON
post-extract: