aboutsummaryrefslogtreecommitdiffstats
path: root/devel/swig13/files/patch-configure
diff options
context:
space:
mode:
Diffstat (limited to 'devel/swig13/files/patch-configure')
-rw-r--r--devel/swig13/files/patch-configure22
1 files changed, 22 insertions, 0 deletions
diff --git a/devel/swig13/files/patch-configure b/devel/swig13/files/patch-configure
new file mode 100644
index 000000000000..d4c694cd0142
--- /dev/null
+++ b/devel/swig13/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.orig Sat Sep 23 02:14:04 2000
++++ configure Sat Jun 9 12:08:08 2001
+@@ -2684,7 +2684,7 @@
+ echo $ac_n "checking for Ruby header files""... $ac_c" 1>&6
+ echo "configure:2686: checking for Ruby header files" >&5
+ if test -n "$RUBY"; then
+- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
++ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG["archdir"] || $archdir') 2>/dev/null`
+ if test "$RUBYDIR" != ""; then
+ dirs="$RUBYDIR"
+ RUBYINCLUDE=none
+--- configure.in.orig Sat Sep 23 02:14:03 2000
++++ configure.in Sat Jun 9 11:55:20 2001
+@@ -631,7 +631,7 @@
+ fi
+ AC_MSG_CHECKING(for Ruby header files)
+ if test -n "$RUBY"; then
+- RUBYDIR=`($RUBY -rmkmf -e 'print $archdir') 2>/dev/null`
++ RUBYDIR=`($RUBY -rmkmf -e 'print Config::CONFIG[["archdir"]] || $archdir') 2>/dev/null`
+ if test "$RUBYDIR" != ""; then
+ dirs="$RUBYDIR"
+ RUBYINCLUDE=none