aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-PatchReader/Makefile2
-rw-r--r--devel/p5-PatchReader/files/patch-lib__PatchReader__Raw.pm24
2 files changed, 22 insertions, 4 deletions
diff --git a/devel/p5-PatchReader/Makefile b/devel/p5-PatchReader/Makefile
index dedaff01c210..c8927ef52601 100644
--- a/devel/p5-PatchReader/Makefile
+++ b/devel/p5-PatchReader/Makefile
@@ -3,7 +3,7 @@
PORTNAME= PatchReader
PORTVERSION= 0.9.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:TMANNERM
diff --git a/devel/p5-PatchReader/files/patch-lib__PatchReader__Raw.pm b/devel/p5-PatchReader/files/patch-lib__PatchReader__Raw.pm
index 84b6ff5a2e2e..78368a15df89 100644
--- a/devel/p5-PatchReader/files/patch-lib__PatchReader__Raw.pm
+++ b/devel/p5-PatchReader/files/patch-lib__PatchReader__Raw.pm
@@ -1,15 +1,33 @@
---- lib/PatchReader/Raw.pm.orig 2014-09-20 06:54:09 UTC
+--- lib/PatchReader/Raw.pm.orig 2015-02-19 16:02:48 UTC
+++ lib/PatchReader/Raw.pm
-@@ -41,7 +41,7 @@
+@@ -40,8 +40,25 @@ sub next_line {
+
return if $line =~ /^\?/;
++ # FreeBSD bug #197607 - svn property changes are
++ # displayed as line additions in Bugzilla. We'll
++ # just ignore the whole property section.
++ if ($this->{in_prop} == 1) {
++ if ($line =~ /^Index:\s*([\S ]+)/) {
++ # End of property changes, continue normally.
++ $this->{in_prop} = 0;
++ } else {
++ # Ignore property lines
++ return;
++ }
++ } elsif ($line =~ /^Property changes on:.*$/) {
++ # SVN property changes, skip everything until the next index...
++ $this->{in_prop} = 1;
++ return;
++ }
++
# patch header parsing
- if ($line =~ /^---\s*([\S ]+)\s*\t([^\t\r\n]*)\s*(\S*)/) {
+ if ($line =~ /^---\s+([\S ]+)\s*?(?:\t([^\t\r\n]*)\s*(\S*))?/) {
$this->_maybe_end_file();
if ($1 eq "/dev/null") {
-@@ -54,9 +54,11 @@
+@@ -54,9 +71,11 @@ sub next_line {
$this->{IN_HEADER} = 1;