aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/lwp/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/lwp/Makefile b/devel/lwp/Makefile
index 38294a3147fb..481aec406c5c 100644
--- a/devel/lwp/Makefile
+++ b/devel/lwp/Makefile
@@ -19,4 +19,10 @@ USE_LIBTOOL= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "alpha"
+BROKEN= "Does not compile on !i386 and !alpha"
+.endif
+
+.include <bsd.port.post.mk>