aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/upnp/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/devel/upnp/Makefile b/devel/upnp/Makefile
index 7fd880eba5a9..2a31ae3bc84e 100644
--- a/devel/upnp/Makefile
+++ b/devel/upnp/Makefile
@@ -19,18 +19,13 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-CONFIGURE_ARGS+= --with-documentation=${DOCSDIR}
PORTDOCS= *
-.else
-CONFIGURE_ARGS+= --without-documentation
-.endif
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug
-.endif
+OPTIONS_DEFINE= DEBUG DOCS
+
+DEBUG_CONFIGURE_ON= --enable-debug
+DOCS_CONFIGURE_ON= --with-documentation=${DOCSDIR}
+DOCS_CONFIGURE_OFF= --without-documentation
post-patch: .SILENT
${REINPLACE_CMD} '/^pkgconfigexecdir/s|$$(libdir)|$$(prefix)/libdata|' \