aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-WWW-Mechanize/Makefile35
-rw-r--r--devel/p5-Test-WWW-Mechanize/distinfo2
-rw-r--r--devel/p5-Test-WWW-Mechanize/pkg-descr4
-rw-r--r--devel/p5-Test-WWW-Mechanize/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 26d78cc5c2d5..ff7a9792bb31 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1066,6 +1066,7 @@
SUBDIR += p5-Test-Simple
SUBDIR += p5-Test-Tester
SUBDIR += p5-Test-Unit
+ SUBDIR += p5-Test-WWW-Mechanize
SUBDIR += p5-Tie-Array-Sorted
SUBDIR += p5-Tie-Cache
SUBDIR += p5-Tie-DB_File-SplitHash
diff --git a/devel/p5-Test-WWW-Mechanize/Makefile b/devel/p5-Test-WWW-Mechanize/Makefile
new file mode 100644
index 000000000000..4fe381b5d00c
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-WWW-Mechanize
+# Date created: 2005-02-13
+# Whom: aturetta@commit.it
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-WWW-Mechanize
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Testing-specific WWW::Mechanize subclass
+
+BUILD_DEPENDS= ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize \
+ ${SITE_PERL}/Test/LongString.pm:${PORTSDIR}/devel/p5-Test-LongString
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::WWW::Mechanize.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/Test/Builder.pm:${PORTSDIR}/devel/p5-Test-Simple
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-WWW-Mechanize/distinfo b/devel/p5-Test-WWW-Mechanize/distinfo
new file mode 100644
index 000000000000..92eac28efb3b
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/distinfo
@@ -0,0 +1,2 @@
+MD5 (Test-WWW-Mechanize-1.02.tar.gz) = cf36b040879dd1053696b565fe16839b
+SIZE (Test-WWW-Mechanize-1.02.tar.gz) = 6191
diff --git a/devel/p5-Test-WWW-Mechanize/pkg-descr b/devel/p5-Test-WWW-Mechanize/pkg-descr
new file mode 100644
index 000000000000..1f44f476eafa
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/pkg-descr
@@ -0,0 +1,4 @@
+Test::WWW::Mechanize is a subclass of WWW::Mechanize that incorporates
+features for web application testing.
+
+WWW: http://search.cpan.org/dist/Test-WWW-Mechanize/
diff --git a/devel/p5-Test-WWW-Mechanize/pkg-plist b/devel/p5-Test-WWW-Mechanize/pkg-plist
new file mode 100644
index 000000000000..840da9b7293c
--- /dev/null
+++ b/devel/p5-Test-WWW-Mechanize/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/WWW/Mechanize.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW/Mechanize
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Test 2>/dev/null || true