aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/transwarp/Makefile32
-rw-r--r--devel/transwarp/distinfo3
-rw-r--r--devel/transwarp/pkg-descr5
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b860852a0383..7ded8bf1fd3e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6852,6 +6852,7 @@
SUBDIR += tortoisehg
SUBDIR += tpasm
SUBDIR += tradcpp
+ SUBDIR += transwarp
SUBDIR += treepy.el
SUBDIR += trellis
SUBDIR += trio
diff --git a/devel/transwarp/Makefile b/devel/transwarp/Makefile
new file mode 100644
index 000000000000..da680201aa23
--- /dev/null
+++ b/devel/transwarp/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= transwarp
+DISTVERSION= 2.2.1-4
+DISTVERSIONSUFFIX= -ge5ce19e
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ header-only library for task concurrency
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= cmake compiler:c++17-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= bloomen
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/transwarp.h
+
+do-install: # https://github.com/bloomen/transwarp/issues/32
+ ${INSTALL_DATA} ${WRKSRC}/src/transwarp.h ${STAGEDIR}${PREFIX}/include
+
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
+
+.include <bsd.port.mk>
diff --git a/devel/transwarp/distinfo b/devel/transwarp/distinfo
new file mode 100644
index 000000000000..b0dea36304c1
--- /dev/null
+++ b/devel/transwarp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610519640
+SHA256 (bloomen-transwarp-2.2.1-4-ge5ce19e_GH0.tar.gz) = 2a55cbed62793e7580fce764a27cf43f7046a3e00c1ce1b0b402386896dd3661
+SIZE (bloomen-transwarp-2.2.1-4-ge5ce19e_GH0.tar.gz) = 961078
diff --git a/devel/transwarp/pkg-descr b/devel/transwarp/pkg-descr
new file mode 100644
index 000000000000..7e77a4a82c4c
--- /dev/null
+++ b/devel/transwarp/pkg-descr
@@ -0,0 +1,5 @@
+transwarp is a header-only C++ library for task concurrency. It allows you to
+easily create a graph of tasks where every task can be executed asynchronously.
+transwarp is written in C++17 and only depends on the standard library.
+
+WWW: https://github.com/bloomen/transwarp