aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/pear-HTML_Template_Flexy/Makefile54
-rw-r--r--devel/pear-HTML_Template_Flexy/distinfo5
2 files changed, 34 insertions, 25 deletions
diff --git a/devel/pear-HTML_Template_Flexy/Makefile b/devel/pear-HTML_Template_Flexy/Makefile
index d1ab09c2eb04..9f4581c18861 100644
--- a/devel/pear-HTML_Template_Flexy/Makefile
+++ b/devel/pear-HTML_Template_Flexy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTML_Template_Flexy
-PORTVERSION= 1.2.1
+PORTVERSION= 1.2.3
CATEGORIES= devel www pear
MAINTAINER= antonio@php.net
@@ -21,39 +21,48 @@ OPTIONS= PEAR_HTML_JAVASCRIPT "PEAR::HTML_Javascript support" off \
PEAR_TRANSLATION2 "PEAR::Translation2 support" off
CATEGORY= HTML/Template
-FILES= Flexy.php Flexy/example.ini Flexy/Element.php Flexy/Element/Xul.php \
- Flexy/Factory.php Flexy/Assign.php Flexy/Plugin.php \
- Flexy/Plugin/Savant.php Flexy/SmartyAPI.php Flexy/Translator.php \
- Flexy/templates/translator.html Flexy/compileAll.php Flexy/Tree.php \
- Flexy/Tokenizer.php Flexy/Token.php Flexy/Token/Tag.php \
- Flexy/Token/EndTag.php Flexy/Token/If.php Flexy/Token/Else.php \
- Flexy/Token/End.php Flexy/Token/Foreach.php Flexy/Token/Var.php \
- Flexy/Token/Method.php Flexy/Token/Processing.php Flexy/Token/Text.php \
- Flexy/Test.php Flexy/Compiler.php Flexy/Compiler/Flexy.php \
- Flexy/Compiler/Flexy/Tag.php Flexy/Compiler/Flexy/Flexy.php \
- Flexy/Compiler/Standard.php Flexy/Compiler/Standard/Tag.php \
+FILES= Flexy.php Flexy/example.ini Flexy/Element.php \
+ Flexy/Element/Xul.php Flexy/Factory.php Flexy/Assign.php \
+ Flexy/Plugin.php Flexy/Plugin/Savant.php Flexy/SmartyAPI.php \
+ Flexy/Translator.php Flexy/templates/translator.html \
+ Flexy/compileAll.php Flexy/Tree.php Flexy/Tokenizer.php \
+ Flexy/Token.php Flexy/Token/Tag.php Flexy/Token/EndTag.php \
+ Flexy/Token/If.php Flexy/Token/Else.php Flexy/Token/End.php \
+ Flexy/Token/Foreach.php Flexy/Token/Var.php \
+ Flexy/Token/Method.php Flexy/Token/Processing.php \
+ Flexy/Token/Text.php Flexy/Test.php Flexy/Compiler.php \
+ Flexy/Compiler/Flexy.php Flexy/Compiler/Flexy/Tag.php \
+ Flexy/Compiler/Flexy/Flexy.php Flexy/Compiler/Standard.php \
+ Flexy/Compiler/Standard/Tag.php \
Flexy/Compiler/Standard/Flexy.php Flexy/Compiler/Regex.php \
Flexy/Compiler/Regex/BodyOnly.php Flexy/Compiler/Regex/Php.php \
- Flexy/Compiler/Regex/RtfSimpleTags.php Flexy/Compiler/Regex/SimpleTags.php \
+ Flexy/Compiler/Regex/RtfSimpleTags.php \
+ Flexy/Compiler/Regex/SimpleTags.php \
Flexy/Compiler/Regex/Mail.php Flexy/Compiler/Regex/Xml.php \
Flexy/Compiler/Regex/Math.php Flexy/Compiler/SmartyConvertor.php
TESTS= testsuite.php test_blocks.html.phpt test_bug_2959.html.phpt \
test_conditions.html.phpt test_error_foreach.html.phpt \
test_flexy_tojavascript.html.phpt test_forms.html.phpt \
- test_function.html.phpt test_globals.html.phpt test_image_view.html.phpt \
- test_include.html.phpt test_javascript.html.phpt test_looping.html.phpt \
+ test_function.html.phpt test_globals.html.phpt \
+ test_image_view.html.phpt test_include.html.phpt \
+ test_javascript.html.phpt test_looping.html.phpt \
test_methods.html.phpt test_namespaces.html.phpt \
test_plugin_modifiers.html.phpt test_raw_php.html.phpt \
- test_raw_text.html.phpt test_style.html.phpt test_variables.html.phpt \
- templates/blocks.html templates/bug_2959.html templates/conditions.html \
+ test_raw_text.html.phpt test_style.html.phpt \
+ test_variables.html.phpt templates/blocks.html \
+ templates/bug_2959.html templates/conditions.html \
templates/error_foreach.html templates/flexy_tojavascript.html \
- templates/forms.html templates/function.html templates/globals.html \
- templates/image_view.html templates/include.html templates/javascript.html \
- templates/looping.html templates/methods.html templates/namespaces.html \
- templates/plugin_modifiers.html templates/raw_php.html \
- templates/raw_text.html templates/style.html templates/variables.html \
+ templates/forms.html templates/function.html \
+ templates/globals.html templates/image_view.html \
+ templates/include.html templates/javascript.html \
+ templates/looping.html templates/methods.html \
+ templates/namespaces.html templates/plugin_modifiers.html \
+ templates/raw_php.html templates/raw_text.html \
+ templates/style.html templates/variables.html \
smarty/smartytest.php
+.include <bsd.port.pre.mk>
+
.if defined(WITH_PEAR_HTML_JAVASCRIPT)
RUN_DEPENDS+= ${PEARDIR}/HTML/Javascript.php:${PORTSDIR}/devel/pear-HTML_Javascript
.endif
@@ -66,6 +75,5 @@ RUN_DEPENDS+= ${PEARDIR}/File/Gettext.php:${PORTSDIR}/sysutils/pear-File_Gettext
RUN_DEPENDS+= ${PEARDIR}/Translation2.php:${PORTSDIR}/sysutils/pear-Translation2
.endif
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_Template_Flexy/distinfo b/devel/pear-HTML_Template_Flexy/distinfo
index b981bd970861..5fe90c3a2798 100644
--- a/devel/pear-HTML_Template_Flexy/distinfo
+++ b/devel/pear-HTML_Template_Flexy/distinfo
@@ -1,2 +1,3 @@
-MD5 (PEAR/HTML_Template_Flexy-1.2.1.tgz) = 592cae803cbd743b4bb98404a48b6952
-SIZE (PEAR/HTML_Template_Flexy-1.2.1.tgz) = 117996
+MD5 (PEAR/HTML_Template_Flexy-1.2.3.tgz) = 9cfaf2d23563a2d3784f5e04c7c4a97a
+SHA256 (PEAR/HTML_Template_Flexy-1.2.3.tgz) = e02b3c4cea7e2ac29ce8f8030de424de0a68d0ab90d3d8ca8de5dfb8b218b4b7
+SIZE (PEAR/HTML_Template_Flexy-1.2.3.tgz) = 118268