aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ocaml-ulex/Makefile20
-rw-r--r--devel/ocaml-ulex/distinfo6
-rw-r--r--devel/ocaml-ulex/pkg-install9
3 files changed, 10 insertions, 25 deletions
diff --git a/devel/ocaml-ulex/Makefile b/devel/ocaml-ulex/Makefile
index e0fc16b24d98..9367782dd609 100644
--- a/devel/ocaml-ulex/Makefile
+++ b/devel/ocaml-ulex/Makefile
@@ -7,26 +7,23 @@
#
PORTNAME= ulex
-PORTVERSION= 0.9
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= devel
MASTER_SITES= http://www.cduce.org/download/
PKGNAMEPREFIX= ocaml-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@stack.nl
COMMENT= A lexer generator for Unicode and OCaml
-BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib
-RUN_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
- ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+USE_OCAML= true
+USE_OCAML_FINDLIB= true
+USE_OCAML_LDCONFIG= true
+OCAMLC_DEPEND= ocaml>=3.10:${OCAMLC_PORT}
ALL_TARGET= all all.opt
USE_GMAKE= yes
-MAKE_ENV= OCAMLFIND_DESTDIR="${PREFIX}/lib/ocaml/site-lib"
-
.if !defined(NOPORTDOCS)
ALL_TARGET+= doc
PORTDOCS= *
@@ -35,11 +32,8 @@ PORTDOCS= *
PKGDEINSTALL= ${PKGINSTALL}
post-install:
- @${FIND} ${PREFIX}/lib/ocaml/site-lib/${PORTNAME} -type f | \
+ @${FIND} ${PREFIX}/${OCAML_SITELIBDIR}/${PORTNAME} -type f | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${ECHO_CMD} "@dirrm lib/ocaml/site-lib/${PORTNAME}" >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec ocamlfind remove ${PORTNAME} 2>/dev/null || true" >> ${TMPPLIST}
- ${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.html ${WRKSRC}/*.css ${DOCSDIR}
diff --git a/devel/ocaml-ulex/distinfo b/devel/ocaml-ulex/distinfo
index bb7b2e0cc07b..c5556780a198 100644
--- a/devel/ocaml-ulex/distinfo
+++ b/devel/ocaml-ulex/distinfo
@@ -1,3 +1,3 @@
-MD5 (ulex-0.9.tar.gz) = 85dd1e86c29d57c6bf4856fb40ffe77f
-SHA256 (ulex-0.9.tar.gz) = 2bc98970bbb8356e4c5872403fc5e3fa5cf3062bc68656f9c808c4dc4f2f04f9
-SIZE (ulex-0.9.tar.gz) = 20228
+MD5 (ulex-1.0.tar.gz) = 7fb5b571304394ea7a14311e0018cdf6
+SHA256 (ulex-1.0.tar.gz) = d2a55e19c836d0408af232a3cf2c2f72bfd5c30fd9bd2b49ed2e6e0ad8a5cc6e
+SIZE (ulex-1.0.tar.gz) = 19794
diff --git a/devel/ocaml-ulex/pkg-install b/devel/ocaml-ulex/pkg-install
deleted file mode 100644
index 6b2520e4454f..000000000000
--- a/devel/ocaml-ulex/pkg-install
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" ]; then
- echo "${PKG_PREFIX}/lib/ocaml/site-lib/ulex" >> ${PKG_PREFIX}/lib/ocaml/ld.conf
-elif [ "$2" = "DEINSTALL" ]; then
- mv ${PKG_PREFIX}/lib/ocaml/ld.conf ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
- grep -v ulex ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp > ${PKG_PREFIX}/lib/ocaml/ld.conf
- rm -f ${PKG_PREFIX}/lib/ocaml/ld.conf.tmp
-fi