aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/as31/Makefile4
-rw-r--r--devel/avr-gcc-3/Makefile3
-rw-r--r--devel/avr-gcc/Makefile4
-rw-r--r--devel/bison/Makefile31
-rw-r--r--devel/bison/distinfo6
-rw-r--r--devel/bison/pkg-plist57
-rw-r--r--devel/bison2/Makefile67
-rw-r--r--devel/bison2/distinfo3
-rw-r--r--devel/bison2/pkg-descr22
-rw-r--r--devel/bison2/pkg-plist73
-rw-r--r--devel/cross-gcc/Makefile4
-rw-r--r--devel/eboxy/Makefile4
-rw-r--r--devel/hp48cc/Makefile4
-rw-r--r--devel/kimwitu++/Makefile4
-rw-r--r--devel/kscope/Makefile3
-rw-r--r--devel/libIDL/Makefile3
-rw-r--r--devel/libbonobo/Makefile4
-rw-r--r--devel/libmimedir/Makefile3
-rw-r--r--devel/libvc/Makefile4
-rw-r--r--devel/powerpc-gcc/Makefile4
-rw-r--r--devel/pwlib/Makefile4
-rw-r--r--devel/py-bison/Makefile3
-rw-r--r--devel/ragel/Makefile3
-rw-r--r--devel/ruby-rbison/Makefile5
-rw-r--r--devel/sfslite/Makefile3
-rw-r--r--devel/sourcenav/Makefile4
-rw-r--r--devel/tavrasm/Makefile3
-rw-r--r--devel/tigcc/Makefile3
29 files changed, 120 insertions, 216 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4c411d45c75d..1a835aeaa585 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -96,7 +96,6 @@
SUBDIR += bicyclerepair
SUBDIR += bin86
SUBDIR += bison
- SUBDIR += bison2
SUBDIR += bisongen
SUBDIR += bnf
SUBDIR += bnfc
diff --git a/devel/as31/Makefile b/devel/as31/Makefile
index 02ab135bfcf7..aa007b016485 100644
--- a/devel/as31/Makefile
+++ b/devel/as31/Makefile
@@ -7,7 +7,7 @@
PORTNAME= as31
PORTVERSION= 2.0.b3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= http://www.pjrc.com/tech/8051/tools/
DISTNAME= ${PORTNAME}_beta3
@@ -22,7 +22,7 @@ PLIST_SUB+= X11=""
ALL_TARGET= as31
PLIST_SUB+= X11="@comment "
.endif
-USE_BISON= YES
+USE_BISON= build
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 19b70a212229..d0f860f62cc0 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gcc-3
PORTVERSION= 3.4.6
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
@@ -32,7 +33,7 @@ USE_AUTOTOOLS= autoheader:213
USE_PERL5_BUILD= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
GNU_CONFIGURE= yes
CONFLICTS= avr-gcc-4*
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 8ffb249d8008..572939a9b90b 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 4.1.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITES+= http://people.freebsd.org/~joerg/:local
@@ -37,7 +37,7 @@ NO_LATEST_LINK= Use devel/avr-gcc for a stable version.
USE_PERL5_BUILD= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
diff --git a/devel/bison/Makefile b/devel/bison/Makefile
index 3e1ab006463a..892388d48c68 100644
--- a/devel/bison/Makefile
+++ b/devel/bison/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= bison
-PORTVERSION= 1.75
-PORTREVISION= 2
-PORTEPOCH= 1
+PORTVERSION= 2.3
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,20 +18,18 @@ COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-CONFLICTS= bison-1.8[0-9]* bison-2.[0-9]*
-
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- MAKEINFO="makeinfo --no-split"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= bison.1
INFO= bison
+CONFIGURE_ARGS+=--disable-yacc
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
@@ -43,7 +40,23 @@ PLIST_SUB+= NLS=""
.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
+.include <bsd.port.pre.mk>
+
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
-.include <bsd.port.mk>
+#
+# Requires texinfo 4.8 or above
+#
+.if ${OSVERSION} < 601000
+ @${REINPLACE_CMD} "/^@headitem/d" ${WRKSRC}/doc/bison.texinfo
+.endif
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}/calc++
+ ${INSTALL_DATA} ${WRKSRC}/examples/calc++/*.[chly]* \
+ ${EXAMPLESDIR}/calc++
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/bison/distinfo b/devel/bison/distinfo
index 609880e11758..3278ac334b57 100644
--- a/devel/bison/distinfo
+++ b/devel/bison/distinfo
@@ -1,3 +1,3 @@
-MD5 (bison-1.75.tar.bz2) = dd88fe42e35d554c00af430a9342456a
-SHA256 (bison-1.75.tar.bz2) = dcdf92c9d847798366f31633e8a58ffd4b4e60c94a36bdc343eef81275e0182a
-SIZE (bison-1.75.tar.bz2) = 773106
+MD5 (bison-2.3.tar.bz2) = c18640c6ec31a169d351e3117ecce3ec
+SHA256 (bison-2.3.tar.bz2) = b10d7e9e354be72aee4e4911cf19dd27b5c527d4e7200857365b5fcdeea0dffb
+SIZE (bison-2.3.tar.bz2) = 1080319
diff --git a/devel/bison/pkg-plist b/devel/bison/pkg-plist
index f1d3f5a225f8..87d19fca0dd0 100644
--- a/devel/bison/pkg-plist
+++ b/devel/bison/pkg-plist
@@ -1,23 +1,72 @@
-@comment $FreeBSD$
bin/bison
+share/aclocal/bison-i18n.m4
+%%DATADIR%%/README
+%%DATADIR%%/c++.m4
%%DATADIR%%/c.m4
%%DATADIR%%/glr.c
+%%DATADIR%%/glr.cc
%%DATADIR%%/lalr1.cc
+%%DATADIR%%/location.cc
%%DATADIR%%/m4sugar/m4sugar.m4
-%%DATADIR%%/m4sugar/version.m4
%%DATADIR%%/yacc.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-driver.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-driver.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.yy
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-scanner.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-scanner.ll
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++.cc
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/location.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/position.hh
+%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/stack.hh
+%%NLS%%share/locale/da/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/da/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/de/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/de/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/es/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/es/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/et/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/et/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/fr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/hr/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/id/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/id/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/it/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/it/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/ja/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/nl/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/ru/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/sv/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/bison-runtime.mo
%%NLS%%share/locale/tr/LC_MESSAGES/bison.mo
-@dirrm %%DATADIR%%/m4sugar
-@dirrm %%DATADIR%%
+%%NLS%%share/locale/vi/LC_MESSAGES/bison-runtime.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/bison.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/bison-runtime.mo
+%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/rw
+%%PORTDOCS%%@dirrmtry %%EXAMPLESDIR%%/calc++
+%%PORTDOCS%%@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry %%DATADIR%%/m4sugar
+@dirrmtry %%DATADIR%%
diff --git a/devel/bison2/Makefile b/devel/bison2/Makefile
deleted file mode 100644
index 16b48e68deb8..000000000000
--- a/devel/bison2/Makefile
+++ /dev/null
@@ -1,67 +0,0 @@
-# Ports collection makefile for: bison
-# Date created: 27 Mar 1999
-# Whom: Jerry Hicks
-#
-# $FreeBSD$
-#
-
-PORTNAME= bison
-PORTVERSION= 2.3
-PORTREVISION= 1
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ade@FreeBSD.org
-COMMENT= A parser generator from FSF, (mostly) compatible with Yacc
-
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
-RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-
-CONFLICTS= bison-1.*
-
-NO_LATEST_LINK= yes
-USE_BZIP2= yes
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-
-MAN1= bison.1
-INFO= bison
-
-CONFIGURE_ARGS+=--disable-yacc
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
-.ifdef USE_BISON
-.error You have `USE_BISON' variable defined either in environment or in make(1) arguments. Please undefine and try again.
-.endif
-
-.include <bsd.port.pre.mk>
-
-post-extract:
- @${RM} -f ${WRKSRC}/doc/bison.info*
-
-#
-# Requires texinfo 4.8 or above
-#
-.if ${OSVERSION} < 601000
- @${REINPLACE_CMD} "/^@headitem/d" ${WRKSRC}/doc/bison.texinfo
-.endif
-
-post-install:
- ${LN} -sf ${PREFIX}/bin/bison ${PREFIX}/bin/bison2
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${EXAMPLESDIR}/calc++
- ${INSTALL_DATA} ${WRKSRC}/examples/calc++/*.[chly]* \
- ${EXAMPLESDIR}/calc++
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/devel/bison2/distinfo b/devel/bison2/distinfo
deleted file mode 100644
index 3278ac334b57..000000000000
--- a/devel/bison2/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (bison-2.3.tar.bz2) = c18640c6ec31a169d351e3117ecce3ec
-SHA256 (bison-2.3.tar.bz2) = b10d7e9e354be72aee4e4911cf19dd27b5c527d4e7200857365b5fcdeea0dffb
-SIZE (bison-2.3.tar.bz2) = 1080319
diff --git a/devel/bison2/pkg-descr b/devel/bison2/pkg-descr
deleted file mode 100644
index c968b052baf7..000000000000
--- a/devel/bison2/pkg-descr
+++ /dev/null
@@ -1,22 +0,0 @@
-Bison is a tool used to write parsers, such as the parser for GNU cc.
-It is similar to Yacc, which is included in the base FreeBSD system.
-
-The main difference between Bison and Yacc that I know of is that
-Bison supports the @N construction, which gives you access to
-the starting and ending line number and character number associated
-with any of the symbols in the current rule.
-
-Also, Bison supports the command `%expect N' which says not to mention
-the conflicts if there are N shift/reduce conflicts and no reduce/reduce
-conflicts.
-
-The differences in the algorithms stem mainly from the horrible
-kludges that Johnson had to perpetrate to make Yacc fit in a PDP-11.
-
-Also, Bison uses a faster but less space-efficient encoding for the
-parse tables (see Corbett's PhD thesis from Berkeley, "Static
-Semantics in Compiler Error Recovery", June 1985, Report No. UCB/CSD
-85/251), and more modern technique for generating the lookahead sets.
-(See "Efficient Construction of LALR(1) Lookahead Sets" by F. DeRemer
-and A. Pennello, in ACM TOPLS Vol 4 No 4, October 1982. Their
-technique is the standard one now.)
diff --git a/devel/bison2/pkg-plist b/devel/bison2/pkg-plist
deleted file mode 100644
index c8e3bbeb1d1b..000000000000
--- a/devel/bison2/pkg-plist
+++ /dev/null
@@ -1,73 +0,0 @@
-bin/bison
-bin/bison2
-share/aclocal/bison-i18n.m4
-%%DATADIR%%/README
-%%DATADIR%%/c++.m4
-%%DATADIR%%/c.m4
-%%DATADIR%%/glr.c
-%%DATADIR%%/glr.cc
-%%DATADIR%%/lalr1.cc
-%%DATADIR%%/location.cc
-%%DATADIR%%/m4sugar/m4sugar.m4
-%%DATADIR%%/yacc.c
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-driver.cc
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-driver.hh
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.cc
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.hh
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-parser.yy
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-scanner.cc
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++-scanner.ll
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/calc++.cc
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/location.hh
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/position.hh
-%%PORTDOCS%%%%EXAMPLESDIR%%/calc++/stack.hh
-%%NLS%%share/locale/da/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/da/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/de/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/de/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/es/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/es/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/et/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/et/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/ga/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/ga/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/id/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/id/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/it/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/it/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/rw/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/rw/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/bison-runtime.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/bison.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/bison-runtime.mo
-%%NLS%%@dirrmtry share/locale/rw/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/rw
-%%PORTDOCS%%@dirrmtry %%EXAMPLESDIR%%/calc++
-%%PORTDOCS%%@dirrmtry %%EXAMPLESDIR%%
-@dirrmtry %%DATADIR%%/m4sugar
-@dirrmtry %%DATADIR%%
diff --git a/devel/cross-gcc/Makefile b/devel/cross-gcc/Makefile
index c84320388b17..d3c9281c542e 100644
--- a/devel/cross-gcc/Makefile
+++ b/devel/cross-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= gcc
PORTVERSION= 4.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC:S,$,:gcc,} \
${MASTER_SITE_SOURCEWARE:S,$,:newlib,}
@@ -37,7 +37,7 @@ RUN_DEPENDS= ${OURTARGET}-as:${PORTSDIR}/devel/cross-binutils
USE_BZIP2= yes
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
GNU_CONFIGURE= yes
ALL_TARGET= all info
diff --git a/devel/eboxy/Makefile b/devel/eboxy/Makefile
index bdea0474ea3f..a197e8a00290 100644
--- a/devel/eboxy/Makefile
+++ b/devel/eboxy/Makefile
@@ -8,7 +8,7 @@
PORTNAME= eboxy
PORTVERSION= 0.4.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Create simple GUI interfaces for entertainment PC
-USE_BISON= yes
+USE_BISON= build
USE_BZIP2= yes
USE_SDL= sdl gui mixer
USE_GNOME= gnometarget libxml2 lthack
diff --git a/devel/hp48cc/Makefile b/devel/hp48cc/Makefile
index 75b1a45addf9..1fb6fb9a3385 100644
--- a/devel/hp48cc/Makefile
+++ b/devel/hp48cc/Makefile
@@ -7,14 +7,14 @@
PORTNAME= hp48cc
PORTVERSION= 1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lang
MASTER_SITES= http://www.sigala.it/sandro/files/
MAINTAINER= danfe@FreeBSD.org
COMMENT= C-like compiler that translates input code to the HP48 RPN language
-USE_BISON= yes
+USE_BISON= build
GNU_CONFIGURE= yes
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
diff --git a/devel/kimwitu++/Makefile b/devel/kimwitu++/Makefile
index 4bc6fe5a2787..5f996782f3cc 100644
--- a/devel/kimwitu++/Makefile
+++ b/devel/kimwitu++/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kimwitu++
PORTVERSION= 2.3.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://www2.informatik.hu-berlin.de/~piefel/kimwitu++/ \
http://www.netsw.org/softeng/compilerconstruct/kimwitu/
@@ -16,7 +16,7 @@ MASTER_SITES= http://www2.informatik.hu-berlin.de/~piefel/kimwitu++/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for processing trees (i.e. terms)
-USE_BISON= yes
+USE_BISON= build
USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/devel/kscope/Makefile b/devel/kscope/Makefile
index 5e7b7733298f..9ce0112bc365 100644
--- a/devel/kscope/Makefile
+++ b/devel/kscope/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kscope
PORTVERSION= 1.6.0
+PORTREVISION= 1
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}/
@@ -14,7 +15,6 @@ MASTER_SITE_SUBDIR=${PORTNAME}/
MAINTAINER= frank@exit.com
COMMENT= KDE front-end to Cscope
-BUILD_DEPENDS+= bison2:${PORTSDIR}/devel/bison2
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
cscope:${PORTSDIR}/devel/cscope \
@@ -22,6 +22,7 @@ RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
DOCSDIR= ${PREFIX}/share/doc/HTML/en/${PORTNAME}
+USE_BISON= build
USE_KDEBASE_VER=3
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
diff --git a/devel/libIDL/Makefile b/devel/libIDL/Makefile
index 790b4cb3204c..e6e165e8bc19 100644
--- a/devel/libIDL/Makefile
+++ b/devel/libIDL/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libIDL
PORTVERSION= 0.8.9
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.8
@@ -18,7 +19,7 @@ COMMENT= A library for creating trees of CORBA IDL files
USE_BZIP2= yes
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
USE_GNOME= gnomehack glib20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index d312ac404f1b..5523bf9dcc41 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -8,7 +8,7 @@
PORTNAME= libbonobo
PORTVERSION= 2.18.0
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -24,7 +24,7 @@ USE_BZIP2= yes
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
USE_GETTEXT= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/devel/libmimedir/Makefile b/devel/libmimedir/Makefile
index 9611e8be5dcc..5b19729c25b7 100644
--- a/devel/libmimedir/Makefile
+++ b/devel/libmimedir/Makefile
@@ -6,6 +6,7 @@
PORTNAME= libmimedir
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= libmimedir
@@ -16,7 +17,7 @@ COMMENT= Library for parsing RFC2425 MIME Directory Profile information
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_BISON= yes
+USE_BISON= build
USE_LDCONFIG= yes
INSTALLS_SHLIB= yes
diff --git a/devel/libvc/Makefile b/devel/libvc/Makefile
index b5200ba50b32..1ab615c37526 100644
--- a/devel/libvc/Makefile
+++ b/devel/libvc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libvc
PORTVERSION= 003
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= rolo
@@ -17,7 +17,7 @@ COMMENT= A vCard library
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
-USE_BISON= yes
+USE_BISON= build
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/devel/powerpc-gcc/Makefile b/devel/powerpc-gcc/Makefile
index ead39093e556..cf4d7f8c875b 100644
--- a/devel/powerpc-gcc/Makefile
+++ b/devel/powerpc-gcc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gcc
PORTVERSION= 4.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/${DISTNAME}
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}
USE_BZIP2= yes
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
GNU_CONFIGURE= yes
STRIP=
NO_MTREE=yes
diff --git a/devel/pwlib/Makefile b/devel/pwlib/Makefile
index f021959247d6..244643060495 100644
--- a/devel/pwlib/Makefile
+++ b/devel/pwlib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pwlib
PORTVERSION= 1.10.3
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.voxgratia.org/releases/
@@ -21,7 +21,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
-USE_BISON= yes
+USE_BISON= build
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:261
USE_GNOME= gnometarget
diff --git a/devel/py-bison/Makefile b/devel/py-bison/Makefile
index 077e9d62661c..e3879c6f1f40 100644
--- a/devel/py-bison/Makefile
+++ b/devel/py-bison/Makefile
@@ -8,6 +8,7 @@
PORTNAME= bison
PORTVERSION= 0.1.8
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.freenet.org.nz/python/pybison/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,8 +18,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Python-based parsing at the speed of C
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Pyrex/__init__.py:${PORTSDIR}/devel/pyrex
-RUN_DEPENDS= bison:${PORTSDIR}/devel/bison
+USE_BISON= run
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGVERSION= 0.1
diff --git a/devel/ragel/Makefile b/devel/ragel/Makefile
index dfbd2fbf8ee5..f4e4829df211 100644
--- a/devel/ragel/Makefile
+++ b/devel/ragel/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ragel
PORTVERSION= 5.23
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.cs.queensu.ca/home/thurston/ragel/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
@@ -17,7 +18,7 @@ COMMENT= Compile regular languages into executable C/C++ code
BUILD_DEPENDS= ${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf
-USE_BISON= yes
+USE_BISON= build
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/ruby-rbison/Makefile b/devel/ruby-rbison/Makefile
index 0ce75810d77d..366673e92925 100644
--- a/devel/ruby-rbison/Makefile
+++ b/devel/ruby-rbison/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rbison
PORTVERSION= 0.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel ruby
MASTER_SITES= http://freebsd.unixfreunde.de/sources/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -16,8 +16,7 @@ DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates a Ruby parser class from a Bison-like specification file
-RUN_DEPENDS= bison:${PORTSDIR}/devel/bison
-
+USE_BISON= run
USE_RUBY= yes
RUBY_SHEBANG_FILES= ${WRKSRC}/rbison
diff --git a/devel/sfslite/Makefile b/devel/sfslite/Makefile
index dedaa0ed1667..da40d97ac2c6 100644
--- a/devel/sfslite/Makefile
+++ b/devel/sfslite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sfslite
PORTVERSION= 1.2.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://dist.okws.org/dist/
@@ -22,7 +23,7 @@ USE_GMAKE= yes
#
# rpcc does not work with byacc, so just require BISON
#
-USE_BISON= yes
+USE_BISON= build
#
# Map X.Y.Z.Q => X.Y
diff --git a/devel/sourcenav/Makefile b/devel/sourcenav/Makefile
index 0c9c56b44b3a..e9f32d4a672b 100644
--- a/devel/sourcenav/Makefile
+++ b/devel/sourcenav/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sourcenav
PORTVERSION= 5.1.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= devel
MASTER_SITES= SF
@@ -22,7 +22,7 @@ PREFIX:= ${PREFIX}/${PORTNAME}
.else
PREFIX?= ${LOCALBASE}/${PORTNAME}
.endif
-USE_BISON= yes
+USE_BISON= build
USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
diff --git a/devel/tavrasm/Makefile b/devel/tavrasm/Makefile
index bb62e1c7b4a9..797cc1dca171 100644
--- a/devel/tavrasm/Makefile
+++ b/devel/tavrasm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tavrasm
PORTVERSION= 1.22
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.tavrasm.org/:0
DISTFILES= ${PORTNAME}${EXTRACT_SUFX}:0
@@ -15,8 +16,8 @@ MAINTAINER= wes@FreeBSD.org
COMMENT= Tom's AVR Assembler
EXTRACT_DEPENDS=unzip:${PORTSDIR}/archivers/unzip
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison
+USE_BISON= build
WRKSRC= ${WRKDIR}/tavrasm.122
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/devel/tigcc/Makefile b/devel/tigcc/Makefile
index 063a08905057..d08c19ded092 100644
--- a/devel/tigcc/Makefile
+++ b/devel/tigcc/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tigcc
PORTVERSION= 0.96.b8
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GCC:S/$/:gcc/} \
${MASTER_SITE_GNU:S/$/:gas/} \
@@ -22,7 +23,7 @@ COMMENT= C compiler for the TI89, 92, and 92+ calculators
USE_BZIP2= yes
USE_GMAKE= yes
-USE_BISON= yes
+USE_BISON= build
NO_WRKSUBDIR= yes
do-extract: