aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/lightning/Makefile10
-rw-r--r--devel/lightning/distinfo4
-rw-r--r--devel/lightning/pkg-descr8
-rw-r--r--devel/lightning/pkg-plist1
4 files changed, 11 insertions, 12 deletions
diff --git a/devel/lightning/Makefile b/devel/lightning/Makefile
index 1efe48515328..626e63df009f 100644
--- a/devel/lightning/Makefile
+++ b/devel/lightning/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= lightning
-PORTVERSION= 2.0.4
-PORTREVISION= 1
+PORTVERSION= 2.0.5
CATEGORIES= devel
MASTER_SITES= GNU
@@ -13,17 +12,18 @@ COMMENT= Generates assembly language code at run-time
LICENSE= GPLv3 LGPL3
LICENSE_COMB= multi
+USES= libtool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-disassembler=no
INSTALL_TARGET= install-strip
-USES= libtool
USE_LDCONFIG= yes
-INFO= lightning
-PLIST_SUB+= JIT_ARCH=${ARCH:S/i386/x86/:S/amd64/x86/:S/x86_64/x86/:S/sparc64/sparc/:S/powerpc/ppc/}
+PLIST_SUB= JIT_ARCH=${ARCH:S/i386/x86/:S/amd64/x86/:S/x86_64/x86/:S/sparc64/sparc/:S/powerpc/ppc/}
ONLY_FOR_ARCHS= i386 amd64 arm ia64 powerpc sparc64 mips
+INFO= lightning
+
OPTIONS_DEFINE= ASSERTIONS
ASSERTIONS_DESC=Enable runtime code generation assertions
diff --git a/devel/lightning/distinfo b/devel/lightning/distinfo
index ea26b32bfdb0..d24cd871403c 100644
--- a/devel/lightning/distinfo
+++ b/devel/lightning/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lightning-2.0.4.tar.gz) = be312cd182dfd1373087048cbc89e55cbcb3487329b165ccceb0b4507a9e2cd3
-SIZE (lightning-2.0.4.tar.gz) = 882734
+SHA256 (lightning-2.0.5.tar.gz) = 65b66a86aef8772e8c6813868da5174c4977c65b9e6cff3d4c3bb0de1a52a94a
+SIZE (lightning-2.0.5.tar.gz) = 902646
diff --git a/devel/lightning/pkg-descr b/devel/lightning/pkg-descr
index 1cfdb7fea02b..f878ec1123e9 100644
--- a/devel/lightning/pkg-descr
+++ b/devel/lightning/pkg-descr
@@ -1,6 +1,6 @@
-GNU lightning is a library that generates assembly language code at run-time;
-it is very fast, making it ideal for Just-In-Time compilers, and it abstracts
-over the target CPU, as it exposes to the clients a standardized RISC
-instruction set inspired by the MIPS and SPARC chips.
+GNU lightning is a library that generates assembly language code at
+run-time; it is very fast, making it ideal for Just-In-Time compilers,
+and it abstracts over the target CPU, as it exposes to the clients a
+standardized RISC instruction set inspired by the MIPS and SPARC chips.
WWW: http://www.gnu.org/software/lightning/
diff --git a/devel/lightning/pkg-plist b/devel/lightning/pkg-plist
index 830c27a4bbc4..72e31a5b014f 100644
--- a/devel/lightning/pkg-plist
+++ b/devel/lightning/pkg-plist
@@ -4,4 +4,3 @@ lib/liblightning.a
lib/liblightning.so
lib/liblightning.so.0
lib/liblightning.so.0.0.0
-@dirrm include/lightning