aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/icontheme/Makefile35
-rw-r--r--devel/icontheme/distinfo3
-rw-r--r--devel/icontheme/files/patch-dub.json13
-rw-r--r--devel/icontheme/pkg-descr3
-rw-r--r--devel/icontheme/pkg-plist6
6 files changed, 61 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f1aaeb01e8c2..a560c1aac7d2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1209,6 +1209,7 @@
SUBDIR += ice
SUBDIR += icestorm
SUBDIR += icmake
+ SUBDIR += icontheme
SUBDIR += icu
SUBDIR += icu-le-hb
SUBDIR += icu-lx
diff --git a/devel/icontheme/Makefile b/devel/icontheme/Makefile
new file mode 100644
index 000000000000..bed0657e7788
--- /dev/null
+++ b/devel/icontheme/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= icontheme
+PORTVERSION= 1.2.1
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Icon Theme Specification implementation in D programming language
+
+LICENSE= BSL
+
+BUILD_DEPENDS= ldmd2:lang/ldc \
+ dub:devel/dub \
+ ${LOCALBASE}/lib/d/libisfreedesktop.a:devel/isfreedesktop \
+ ${LOCALBASE}/lib/d/libinilike.a:devel/inilike \
+ ${LOCALBASE}/lib/d/libxdgpaths.a:devel/xdgpaths
+
+USE_GITHUB= yes
+GH_ACCOUNT= FreeSlave
+
+DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
+D_INCLUDE_DIR= ${PREFIX}/include/d
+D_LIB_DIR= ${PREFIX}/lib/d
+
+do-build:
+ @cd ${WRKSRC} && ${DUB_CMD}
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${D_INCLUDE_DIR}
+ @${MKDIR} ${STAGEDIR}${D_LIB_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/lib/libicontheme.a ${STAGEDIR}${D_LIB_DIR}
+ cd ${WRKSRC}/source && ${COPYTREE_SHARE} . ${STAGEDIR}${D_INCLUDE_DIR} "-name *\.d"
+
+.include <bsd.port.mk>
diff --git a/devel/icontheme/distinfo b/devel/icontheme/distinfo
new file mode 100644
index 000000000000..8350159741c3
--- /dev/null
+++ b/devel/icontheme/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1513182539
+SHA256 (FreeSlave-icontheme-v1.2.1_GH0.tar.gz) = 3db256b4f276a981c4405e9b2ccaaf2ad4bfabc5a01ed58e55025414f5a0fef4
+SIZE (FreeSlave-icontheme-v1.2.1_GH0.tar.gz) = 43473
diff --git a/devel/icontheme/files/patch-dub.json b/devel/icontheme/files/patch-dub.json
new file mode 100644
index 000000000000..1a15b2fb991c
--- /dev/null
+++ b/devel/icontheme/files/patch-dub.json
@@ -0,0 +1,13 @@
+--- dub.json.orig 2017-12-13 11:29:42.399563000 -0500
++++ dub.json 2017-12-13 11:29:52.805384000 -0500
+@@ -4,10 +4,6 @@
+ "license" : "BSL-1.0",
+ "copyright": "Copyright © 2015-2016, Roman Chistokhodov",
+ "authors": ["Roman Chistokhodov"],
+- "dependencies": {
+- "inilike": "~>1.1.0",
+- "xdgpaths": "~>0.2.4"
+- },
+ "targetName" : "icontheme",
+ "targetPath" : "lib",
+ "targetType" : "library",
diff --git a/devel/icontheme/pkg-descr b/devel/icontheme/pkg-descr
new file mode 100644
index 000000000000..ceb774145ff5
--- /dev/null
+++ b/devel/icontheme/pkg-descr
@@ -0,0 +1,3 @@
+D library for dealing with icon themes in freedesktop environments
+
+WWW: https://github.com/FreeSlave/icontheme
diff --git a/devel/icontheme/pkg-plist b/devel/icontheme/pkg-plist
new file mode 100644
index 000000000000..7749e4f546bb
--- /dev/null
+++ b/devel/icontheme/pkg-plist
@@ -0,0 +1,6 @@
+include/d/icontheme/cache.d
+include/d/icontheme/file.d
+include/d/icontheme/lookup.d
+include/d/icontheme/package.d
+include/d/icontheme/paths.d
+lib/d/libicontheme.a