aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-VCP/Makefile41
-rw-r--r--devel/p5-VCP/distinfo2
-rw-r--r--devel/p5-VCP/files/patch-lib::VCP::Dest.pm16
-rw-r--r--devel/p5-VCP/pkg-descr7
-rw-r--r--devel/p5-VCP/pkg-plist41
6 files changed, 108 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 843c01408879..f2e0f44c26d5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -895,6 +895,7 @@
SUBDIR += p5-Tree-DAG_Node
SUBDIR += p5-UNIVERSAL-exports
SUBDIR += p5-UNIVERSAL-moniker
+ SUBDIR += p5-VCP
SUBDIR += p5-VCS
SUBDIR += p5-VCS-CVS
SUBDIR += p5-Want
diff --git a/devel/p5-VCP/Makefile b/devel/p5-VCP/Makefile
new file mode 100644
index 000000000000..dcc70110d163
--- /dev/null
+++ b/devel/p5-VCP/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-VCP
+# Date created: 27 February 2004
+# Whom: hrs@FreeBSD.org
+#
+# $FreeBSD$
+
+PORTNAME= VCP
+PORTVERSION= 0.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML/RBS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= A tool for copying files between various SCM repositories
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${SITE_PERL}/XML/ValidWriter.pm:${PORTSDIR}/textproc/p5-XML-AutoWriter \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
+ ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
+ ${SITE_PERL}/Pod/Links.pm:${PORTSDIR}/www/p5-PodToHTML \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${SITE_PERL}/Regexp/Shellish.pm:${PORTSDIR}/devel/p5-Regexp-Shellish
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= vcp.1
+MAN3= RevML::Doctype.3 RevML::Writer.3 VCP.3 \
+ VCP::Debug.3 VCP::Dest.3 VCP::Dest::cvs.3 \
+ VCP::Dest::p4.3 VCP::Dest::revml.3 VCP::Dest::vss.3 \
+ VCP::DiffFormat.3 VCP::License.3 VCP::Maintenance.3 \
+ VCP::Newlines.3 VCP::Patch.3 VCP::Plugin.3 VCP::Process.3 \
+ VCP::Rev.3 VCP::Revs.3 VCP::Source.3 VCP::Source::cvs.3 \
+ VCP::Source::p4.3 VCP::Source::revml.3 VCP::Source::vss.3 \
+ VCP::TestUtils.3 VCP::Utils::cvs.3 VCP::Utils::p4.3 \
+ VCP::Utils::vss.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-VCP/distinfo b/devel/p5-VCP/distinfo
new file mode 100644
index 000000000000..7aca1a353a6a
--- /dev/null
+++ b/devel/p5-VCP/distinfo
@@ -0,0 +1,2 @@
+MD5 (VCP-0.3.tar.gz) = 6589917a4e24c444365f562764d5ef5d
+SIZE (VCP-0.3.tar.gz) = 122937
diff --git a/devel/p5-VCP/files/patch-lib::VCP::Dest.pm b/devel/p5-VCP/files/patch-lib::VCP::Dest.pm
new file mode 100644
index 000000000000..26df369b839b
--- /dev/null
+++ b/devel/p5-VCP/files/patch-lib::VCP::Dest.pm
@@ -0,0 +1,16 @@
+$FreeBSD$
+--- lib/VCP/Dest.pm Fri Feb 27 14:01:18 2004
++++ lib/VCP/Dest.pm Fri Feb 27 14:05:48 2004
+@@ -425,9 +425,9 @@
+ return ( "" ) unless length ;
+
+ return split /(?:
+- (?<=[[:alpha:]])(?=[^[:alpha:]])
+- |(?<=[[:digit:]])(?=[^[:digit:]])
+- |[^[:alnum:]]+
++ (?<=[A-Za-z])(?=[^A-Za-z])
++ |(?<=[0-9])(?=[^0-9])
++ |[^A-Za-z0-9]+
+ )/x ;
+ }
+ }
diff --git a/devel/p5-VCP/pkg-descr b/devel/p5-VCP/pkg-descr
new file mode 100644
index 000000000000..022b15f5a018
--- /dev/null
+++ b/devel/p5-VCP/pkg-descr
@@ -0,0 +1,7 @@
+vcp is a tool for copying revision controlled files between various SCM
+repositories. For example, using vcp, it is possible to copy the contents
+of a entire Perforce depot (or part of one) into a depot on a different
+Perforce server or to copy the contents of a CVS repository into a Perforce
+server (or vice-versa).
+
+WWW: http://public.perforce.com/public/revml/index.html
diff --git a/devel/p5-VCP/pkg-plist b/devel/p5-VCP/pkg-plist
new file mode 100644
index 000000000000..0ef01e720f1a
--- /dev/null
+++ b/devel/p5-VCP/pkg-plist
@@ -0,0 +1,41 @@
+@comment $FreeBSD$
+bin/vcp
+%%SITE_PERL%%/RevML/Doctype.pm
+%%SITE_PERL%%/RevML/Doctype/v0_26.pm
+%%SITE_PERL%%/RevML/Doctype/v0_27.pm
+%%SITE_PERL%%/RevML/Doctype/v0_28.pm
+%%SITE_PERL%%/RevML/Doctype/v0_29.pm
+@unexec rmdir %D/%%SITE_PERL%%/RevML/Doctype 2>/dev/null || true
+%%SITE_PERL%%/RevML/Writer.pm
+@unexec rmdir %D/%%SITE_PERL%%/RevML 2>/dev/null || true
+%%SITE_PERL%%/VCP.pm
+%%SITE_PERL%%/VCP/Debug.pm
+%%SITE_PERL%%/VCP/Dest.pm
+%%SITE_PERL%%/VCP/Dest/cvs.pm
+%%SITE_PERL%%/VCP/Dest/p4.pm
+%%SITE_PERL%%/VCP/Dest/revml.pm
+%%SITE_PERL%%/VCP/Dest/vss.pm
+@unexec rmdir %D/%%SITE_PERL%%/VCP/Dest 2>/dev/null || true
+%%SITE_PERL%%/VCP/DiffFormat.pm
+%%SITE_PERL%%/VCP/License.pod
+%%SITE_PERL%%/VCP/Maintenance.pod
+%%SITE_PERL%%/VCP/Newlines.pod
+%%SITE_PERL%%/VCP/Patch.pm
+%%SITE_PERL%%/VCP/Plugin.pm
+%%SITE_PERL%%/VCP/Process.pod
+%%SITE_PERL%%/VCP/Rev.pm
+%%SITE_PERL%%/VCP/Revs.pm
+%%SITE_PERL%%/VCP/Source.pm
+%%SITE_PERL%%/VCP/Source/cvs.pm
+%%SITE_PERL%%/VCP/Source/p4.pm
+%%SITE_PERL%%/VCP/Source/revml.pm
+%%SITE_PERL%%/VCP/Source/vss.pm
+@unexec rmdir %D/%%SITE_PERL%%/VCP/Source 2>/dev/null || true
+%%SITE_PERL%%/VCP/TestUtils.pm
+%%SITE_PERL%%/VCP/Utils/cvs.pm
+%%SITE_PERL%%/VCP/Utils/p4.pm
+%%SITE_PERL%%/VCP/Utils/vss.pm
+@unexec rmdir %D/%%SITE_PERL%%/VCP/Utils 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/VCP 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/VCP/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/VCP 2>/dev/null || true