aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/qca/Makefile1
-rw-r--r--devel/qca/files/patch-configure9
-rw-r--r--devel/qca/files/patch-r127350859
3 files changed, 69 insertions, 0 deletions
diff --git a/devel/qca/Makefile b/devel/qca/Makefile
index 00ccb0b551ce..d29185ce16e8 100644
--- a/devel/qca/Makefile
+++ b/devel/qca/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qca
PORTVERSION= 2.0.3
+PORTVERSION= 1
CATEGORIES= devel
MASTER_SITES= http://delta.affinix.com/download/qca/2.0/
DISTNAME= qca-${PORTVERSION}
diff --git a/devel/qca/files/patch-configure b/devel/qca/files/patch-configure
index d5d2849efc05..acfe0dc8143b 100644
--- a/devel/qca/files/patch-configure
+++ b/devel/qca/files/patch-configure
@@ -1,5 +1,14 @@
--- ./configure.orig 2008-07-21 21:27:13.000000000 +0400
+++ ./configure 2009-03-15 18:24:58.000000000 +0300
+@@ -382,7 +382,7 @@
+ echo makespec is $defmakespec
+ fi
+
+-qm_spec=""
++qm_spec="$defmakespec"
+ # if the makespec is macx-xcode, force macx-g++
+ if [ "$defmakespec" = "macx-xcode" ]; then
+ qm_spec=macx-g++
@@ -799,10 +799,10 @@
}
diff --git a/devel/qca/files/patch-r1273508 b/devel/qca/files/patch-r1273508
new file mode 100644
index 000000000000..dd6d85b851b1
--- /dev/null
+++ b/devel/qca/files/patch-r1273508
@@ -0,0 +1,59 @@
+--- ./src/botantools/botan/botan/secmem.h 2007-04-20 08:26:13.000000000 +1100
++++ ./src/botantools/botan/botan/secmem.h 2012-05-08 14:54:53.513833555 +1100
+@@ -191,15 +191,15 @@
+ {
+ public:
+ MemoryVector<T>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ MemoryVector(u32bit n = 0) { MemoryRegion<T>::init(false, n); }
+ MemoryVector(const T in[], u32bit n)
+- { MemoryRegion<T>::init(false); set(in, n); }
++ { MemoryRegion<T>::init(false); this->set(in, n); }
+ MemoryVector(const MemoryRegion<T>& in)
+- { MemoryRegion<T>::init(false); set(in); }
++ { MemoryRegion<T>::init(false); this->set(in); }
+ MemoryVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
+- { MemoryRegion<T>::init(false); set(in1); append(in2); }
++ { MemoryRegion<T>::init(false); this->set(in1); append(in2); }
+ };
+
+ /*************************************************
+@@ -210,15 +210,15 @@
+ {
+ public:
+ SecureVector<T>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ SecureVector(u32bit n = 0) { MemoryRegion<T>::init(true, n); }
+ SecureVector(const T in[], u32bit n)
+- { MemoryRegion<T>::init(true); set(in, n); }
++ { MemoryRegion<T>::init(true); this->set(in, n); }
+ SecureVector(const MemoryRegion<T>& in)
+- { MemoryRegion<T>::init(true); set(in); }
++ { MemoryRegion<T>::init(true); this->set(in); }
+ SecureVector(const MemoryRegion<T>& in1, const MemoryRegion<T>& in2)
+- { MemoryRegion<T>::init(true); set(in1); append(in2); }
++ { MemoryRegion<T>::init(true); this->set(in1); append(in2); }
+ };
+
+ /*************************************************
+@@ -229,14 +229,14 @@
+ {
+ public:
+ SecureBuffer<T,L>& operator=(const SecureBuffer<T,L>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+
+ SecureBuffer() { MemoryRegion<T>::init(true, L); }
+ SecureBuffer(const T in[], u32bit n)
+ { MemoryRegion<T>::init(true, L); copy(in, n); }
+ private:
+ SecureBuffer<T, L>& operator=(const MemoryRegion<T>& in)
+- { if(this != &in) set(in); return (*this); }
++ { if(this != &in) this->set(in); return (*this); }
+ };
+
+ }