aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ros-documentation/Makefile3
-rw-r--r--devel/ros-rx/Makefile3
-rw-r--r--devel/ros/Makefile3
-rw-r--r--devel/ros_comm/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/devel/ros-documentation/Makefile b/devel/ros-documentation/Makefile
index b6c208d35393..0e9ac4ebdff3 100644
--- a/devel/ros-documentation/Makefile
+++ b/devel/ros-documentation/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD
WRKSRC= ${WRKDIR}/${PORTNAME}
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
+
LIB_DEPENDS= log4cxx.10:${PORTSDIR}/devel/log4cxx \
boost_python:${PORTSDIR}/devel/boost-python-libs
# we need cmake and gmake for the build, but the build is triggered by make
@@ -48,6 +50,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
.if ${OSVERSION} < 700000
BROKEN=Does not link, librt missing
.endif
diff --git a/devel/ros-rx/Makefile b/devel/ros-rx/Makefile
index b6c208d35393..0e9ac4ebdff3 100644
--- a/devel/ros-rx/Makefile
+++ b/devel/ros-rx/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD
WRKSRC= ${WRKDIR}/${PORTNAME}
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
+
LIB_DEPENDS= log4cxx.10:${PORTSDIR}/devel/log4cxx \
boost_python:${PORTSDIR}/devel/boost-python-libs
# we need cmake and gmake for the build, but the build is triggered by make
@@ -48,6 +50,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
.if ${OSVERSION} < 700000
BROKEN=Does not link, librt missing
.endif
diff --git a/devel/ros/Makefile b/devel/ros/Makefile
index b6c208d35393..0e9ac4ebdff3 100644
--- a/devel/ros/Makefile
+++ b/devel/ros/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD
WRKSRC= ${WRKDIR}/${PORTNAME}
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
+
LIB_DEPENDS= log4cxx.10:${PORTSDIR}/devel/log4cxx \
boost_python:${PORTSDIR}/devel/boost-python-libs
# we need cmake and gmake for the build, but the build is triggered by make
@@ -48,6 +50,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
.if ${OSVERSION} < 700000
BROKEN=Does not link, librt missing
.endif
diff --git a/devel/ros_comm/Makefile b/devel/ros_comm/Makefile
index b6c208d35393..0e9ac4ebdff3 100644
--- a/devel/ros_comm/Makefile
+++ b/devel/ros_comm/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD
WRKSRC= ${WRKDIR}/${PORTNAME}
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
+
LIB_DEPENDS= log4cxx.10:${PORTSDIR}/devel/log4cxx \
boost_python:${PORTSDIR}/devel/boost-python-libs
# we need cmake and gmake for the build, but the build is triggered by make
@@ -48,6 +50,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
+MANUAL_PACKAGE_BUILDING= downloads file after fetch
.if ${OSVERSION} < 700000
BROKEN=Does not link, librt missing
.endif