aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libserver/Makefile21
-rw-r--r--devel/libserver/distinfo3
-rw-r--r--devel/libserver/pkg-descr11
-rw-r--r--devel/libserver/pkg-plist3
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6387c383fda2..8f58079429ef 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -856,6 +856,7 @@
SUBDIR += librelp
SUBDIR += libruin
SUBDIR += libs11n
+ SUBDIR += libserver
SUBDIR += libshbuf
SUBDIR += libshhmsg
SUBDIR += libshhopt
diff --git a/devel/libserver/Makefile b/devel/libserver/Makefile
new file mode 100644
index 000000000000..2aaded75a743
--- /dev/null
+++ b/devel/libserver/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: libserver
+# Date created: Sat, 18 Sept 2010 11:34:25 EDT
+# Whom: James Bailie <jimmy@mammothcheese.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libserver
+PORTVERSION= 1.0
+CATEGORIES= devel
+MASTER_SITES= http://www.mammothcheese.ca/
+
+MAINTAINER= jimmy@mammothcheese.ca
+COMMENT= generic TCP server in a library
+
+MAN8= libserver.8
+MANCOMPRESSED= yes
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libserver/distinfo b/devel/libserver/distinfo
new file mode 100644
index 000000000000..17e9a8cbcc3a
--- /dev/null
+++ b/devel/libserver/distinfo
@@ -0,0 +1,3 @@
+MD5 (libserver-1.0.tar.gz) = dc9957e6b666f4a7b2cfaf2df6ade490
+SHA256 (libserver-1.0.tar.gz) = 9ad0dbf58c2f04175d3d2ac6bdd84fb361868ac74e8708ece466478899ec2dc6
+SIZE (libserver-1.0.tar.gz) = 8540
diff --git a/devel/libserver/pkg-descr b/devel/libserver/pkg-descr
new file mode 100644
index 000000000000..683088e75cf7
--- /dev/null
+++ b/devel/libserver/pkg-descr
@@ -0,0 +1,11 @@
+libserver implements a generic multi-process TCP server which is incapable
+of servicing connections on its own. The programmer writes an
+initialization function and a function to service connections, then
+compiles and links his or her code against the library to create a complete
+multi-process TCP server.
+
+WWW: http://www.mammothcheese.ca/
+
+--
+James Bailie <jimmy@mammothcheese.ca>
+http://www.mammothcheese.ca
diff --git a/devel/libserver/pkg-plist b/devel/libserver/pkg-plist
new file mode 100644
index 000000000000..5b6f769995e8
--- /dev/null
+++ b/devel/libserver/pkg-plist
@@ -0,0 +1,3 @@
+include/server.h
+lib/libserver.so
+lib/libserver.so.1.0