aboutsummaryrefslogtreecommitdiffstats
path: root/dns/bind9-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'dns/bind9-devel/Makefile')
-rw-r--r--dns/bind9-devel/Makefile23
1 files changed, 3 insertions, 20 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index a6ffba5d1048..d79044d7d746 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -30,8 +30,8 @@ COMMENT= BIND DNS suite with updated DNSSEC and DNS64
LICENSE= MPL
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.12.0a.2016.12.23
-HASH= e17d2f9
+ISCVERSION= 9.12.0a.2016.12.28
+HASH= eff07b5
USES= cpe libedit
@@ -71,7 +71,7 @@ OPTIONS_RADIO_GOSTDEF= GOST GOST_ASN1
.if !defined(BIND_TOOLS_SLAVE)
OPTIONS_DEFAULT+= DLZ_FILESYSTEM LMDB RPZ_NSDNAME RPZ_NSIP
-OPTIONS_DEFINE+= LINKS RPZ_NSIP RPZ_NSDNAME DOCS GEOIP \
+OPTIONS_DEFINE+= RPZ_NSIP RPZ_NSDNAME DOCS GEOIP \
MINCACHE PORTREVISION QUERYTRACE LMDB DNSTAP \
START_LATE
OPTIONS_GROUP= DLZ
@@ -102,7 +102,6 @@ QUERYTRACE_DESC= Enable the very verbose query tracelogging
LMDB_DESC= Use LMDB for zone management
DNSTAP_DESC= Provides fast passive logging of DNS messages
-LINKS_DESC= Create conf file symlinks in ${PREFIX}
RPZ_NSIP_DESC= Enable RPZ NSIP trigger rules
RPZ_NSDNAME_DESC= Enable RPZ NSDNAME policy records
DLZ_DESC= Dynamically Loadable Zones
@@ -211,30 +210,16 @@ DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
CONFIGURE_ARGS+= --without-gost
.endif
-.if !${PORT_OPTIONS:MLINKS}
-PKGINSTALL=${NONEXISTENT}
-.endif
-
.if ${PORT_OPTIONS:MTHREADS} && !${PORT_OPTIONS:MDLZ_MYSQL}
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
-.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100)
-PKGINSTALL= ${NONEXISTENT}
-PLIST_SUB+= NOBASE="" BASE="@comment "
-SUB_LIST+= NOBASE="" BASE="@comment "
.if !defined(BIND_TOOLS_SLAVE)
USE_RC_SUBR+= named
SUB_FILES+= named.conf
.endif # !defined(BIND_TOOLS_SLAVE)
-.else
-PLIST_SUB+= NOBASE="@comment " BASE=""
-SUB_LIST+= NOBASE="@comment " BASE=""
-.endif
-
-PKGDEINSTALL= ${PKGINSTALL}
MAKE_JOBS_UNSAFE= yes
@@ -289,7 +274,6 @@ post-install:
${WRKSRC}/HISTORY ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
-.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} >= 1000100)
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mtree
${MKDIR} ${STAGEDIR}${ETCDIR}
.for i in dynamic master slave working
@@ -302,7 +286,6 @@ post-install:
${INSTALL_DATA} ${FILESDIR}/localhost-reverse.db ${STAGEDIR}${ETCDIR}/master
${INSTALL_DATA} ${FILESDIR}/BIND.chroot.dist ${STAGEDIR}${PREFIX}/etc/mtree
${INSTALL_DATA} ${FILESDIR}/BIND.chroot.local.dist ${STAGEDIR}${PREFIX}/etc/mtree
-.endif
${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
${STAGEDIR}${ETCDIR}/rndc.conf.sample