aboutsummaryrefslogtreecommitdiffstats
path: root/dns/djbdns
diff options
context:
space:
mode:
Diffstat (limited to 'dns/djbdns')
-rw-r--r--dns/djbdns/Makefile2
-rw-r--r--dns/djbdns/files/patch-query.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/dns/djbdns/Makefile b/dns/djbdns/Makefile
index 09267d3173ef..980c00bd3477 100644
--- a/dns/djbdns/Makefile
+++ b/dns/djbdns/Makefile
@@ -3,7 +3,7 @@
PORTNAME?= djbdns
PORTVERSION?= ${DJBDNS_VER}
-PORTREVISION?= 21
+PORTREVISION?= 22
PORTEPOCH?= 1
CATEGORIES?= dns
MASTER_SITES= http://cr.yp.to/djbdns/ \
diff --git a/dns/djbdns/files/patch-query.c b/dns/djbdns/files/patch-query.c
new file mode 100644
index 000000000000..34663213dff6
--- /dev/null
+++ b/dns/djbdns/files/patch-query.c
@@ -0,0 +1,20 @@
+--- query.c.orig 2018-01-16 11:49:56.341179000 -0800
++++ query.c 2018-01-16 11:50:06.432700000 -0800
+@@ -203,7 +203,7 @@
+
+
+ NEWNAME:
+- if (++z->loop == 100) goto DIE;
++ if (++z->loop == 500) goto DIE;
+ d = z->name[z->level];
+ dtype = z->level ? DNS_T_A : z->type;
+ dlen = dns_domain_length(d);
+@@ -449,7 +449,7 @@
+
+
+ HAVEPACKET:
+- if (++z->loop == 100) goto DIE;
++ if (++z->loop == 500) goto DIE;
+ buf = z->dt.packet;
+ len = z->dt.packetlen;
+