aboutsummaryrefslogtreecommitdiffstats
path: root/dns
diff options
context:
space:
mode:
Diffstat (limited to 'dns')
-rw-r--r--dns/bind96/Makefile5
-rw-r--r--dns/bind98/Makefile5
-rw-r--r--dns/bind99/Makefile5
3 files changed, 12 insertions, 3 deletions
diff --git a/dns/bind96/Makefile b/dns/bind96/Makefile
index c0b583d3aec1..00687c25f234 100644
--- a/dns/bind96/Makefile
+++ b/dns/bind96/Makefile
@@ -35,7 +35,7 @@ OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
LINKS_DESC= Create conf file symlinks in ${PREFIX}
XML_DESC= Support for xml statistics output
-REPLACE_BASE_DESC= Replace base BIND with this version
+REPLACE_BASE_DESC= Replace base BIND (FreeBSD 9.x and earlier)
LARGE_FILE_DESC= 64-bit file support
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
FIXED_RRSET= Enable fixed rrset ordering
@@ -134,6 +134,9 @@ CONFIGURE_ARGS+= --disable-threads
.endif
.if ${PORT_OPTIONS:MREPLACE_BASE}
+.if ${OSVERSION} >= 1000500
+IGNORE= REPLACE_BASE option not supported on this release
+.endif
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
diff --git a/dns/bind98/Makefile b/dns/bind98/Makefile
index 1b7cc4e7195b..692833e80f76 100644
--- a/dns/bind98/Makefile
+++ b/dns/bind98/Makefile
@@ -35,7 +35,7 @@ OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
LINKS_DESC= Create conf file symlinks in ${PREFIX}
XML_DESC= Support for xml statistics output
-REPLACE_BASE_DESC= Replace base BIND with this version
+REPLACE_BASE_DESC= Replace base BIND (FreeBSD 9.x and earlier)
LARGE_FILE_DESC= 64-bit file support
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
FIXED_RRSET_DESC= Enable fixed rrset ordering
@@ -161,6 +161,9 @@ CONFIGURE_ARGS+= --without-gssapi
.endif
.if ${PORT_OPTIONS:MREPLACE_BASE}
+.if ${OSVERSION} >= 1000500
+IGNORE= REPLACE_BASE option is not supported on this release
+.endif
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
diff --git a/dns/bind99/Makefile b/dns/bind99/Makefile
index 4ee7bbe35c1c..0d3e16be015a 100644
--- a/dns/bind99/Makefile
+++ b/dns/bind99/Makefile
@@ -37,7 +37,7 @@ OPTIONS_GROUP_DLZ= DLZ_POSTGRESQL DLZ_MYSQL DLZ_BDB \
.endif # BIND_TOOLS_SLAVE
SSL_DESC= Build with OpenSSL (Required for DNSSEC)
-REPLACE_BASE_DESC= Replace base BIND with this version
+REPLACE_BASE_DESC= Replace base BIND (FreeBSD 9.x and earlier)
LARGE_FILE_DESC= 64-bit file support
FIXED_RRSET_DESC= Enable fixed rrset ordering
SIGCHASE_DESC= dig/host/nslookup will do DNSSEC validation
@@ -169,6 +169,9 @@ CONFIGURE_ARGS+= --without-gssapi
.endif
.if ${PORT_OPTIONS:MREPLACE_BASE}
+.if ${OSVERSION} >= 1000500
+IGNORE= REPLACE_BASE option is not supported on this release
+.endif
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb