aboutsummaryrefslogtreecommitdiffstats
path: root/editors/leim21/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/leim21/Makefile')
-rw-r--r--editors/leim21/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/editors/leim21/Makefile b/editors/leim21/Makefile
new file mode 100644
index 000000000000..1bdbdfa92a2c
--- /dev/null
+++ b/editors/leim21/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: LEIM for emacs21
+# Date created: 10 September 1998
+# Whom: Shigeyuki FUKUSHIMA <shige@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= leim
+PORTVERSION= 21.1
+CATEGORIES= editors
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= emacs
+
+MAINTAINER= shige@FreeBSD.org
+
+BUILD_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs21
+RUN_DEPENDS= emacs-${EMACS_VER}:${PORTSDIR}/editors/emacs21
+
+USE_GMAKE= yes
+EMACS_VER= 21.1
+WRKSRC= ${WRKDIR}/emacs-${EMACS_VER}/leim
+PLIST_SUB= EMACS_VER=${EMACS_VER}
+SCRIPTS_ENV= EMACS_VER=${EMACS_VER}
+
+pre-install:
+ @${MKDIR} ${PREFIX}/share/emacs/${EMACS_VER}/leim
+
+.include <bsd.port.mk>