aboutsummaryrefslogtreecommitdiffstats
path: root/editors/nano-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/nano-devel/Makefile')
-rw-r--r--editors/nano-devel/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/editors/nano-devel/Makefile b/editors/nano-devel/Makefile
new file mode 100644
index 000000000000..13123870b7e6
--- /dev/null
+++ b/editors/nano-devel/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: nano-devel
+# Date created: 13 November 2008
+# Whom: Eitan Adler <EitanAdlerList@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nano-devel
+PORTVERSION= 2.1.7
+CATEGORIES= editors
+MASTER_SITES= http://www.nano-editor.org/dist/v2.1/ \
+ http://www.ewtoo.org/~astyanax/nano/dist/v2.1/
+DISTNAME= nano-${PORTVERSION}
+
+MAINTAINER= EitanAdlerList@gmail.com
+COMMENT= Nano's ANOther editor, an enhanced free Pico clone
+
+CONFLICTS= nano-2*
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-all --enable-rc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+MANLANG= "" fr
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+INFO= nano
+MAN1= nano.1 rnano.1
+MAN5= nanorc.5
+
+.include <bsd.port.pre.mk>
+
+# requires wide character curses
+.if (${OSVERSION} < 602107) || (${OSVERSION} >= 700000 && ${OSVERSION} < 700033)
+CONFIGURE_ARGS+=--disable-utf8
+.else
+CONFIGURE_ARGS+=--enable-utf8
+.endif
+
+post-build:
+ cd ${WRKSRC}/doc/man; ${REINPLACE_CMD} \
+ -e 's:SYSCONFDIR:${PREFIX}/etc:g' \
+ -e 's:EXAMPLESDIR:${EXAMPLESDIR}:g' \
+ ${MAN1} ${MAN5} ${WRKSRC}/doc/texinfo/${INFO:=.info}
+ ${REINPLACE_CMD} -e 's/\\</[[:<:]]/g' -e 's/\\>/[[:>:]]/g' \
+ ${WRKSRC}/doc/syntax/*.nanorc
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/nanorc.sample ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>