aboutsummaryrefslogtreecommitdiffstats
path: root/editors/nano/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'editors/nano/Makefile')
-rw-r--r--editors/nano/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 76d0ce4e3ab0..e6863c750f81 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -21,13 +21,11 @@ CONFIGURE_ARGS= --docdir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
-MANLANG= "" fr
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
@@ -40,8 +38,6 @@ MAKE_ARGS+= install_htmlmanDATA=""
.endif
INFO= nano
-MAN1= nano.1 rnano.1
-MAN5= nanorc.5
PORTSCOUT= limitw:1,even
@@ -53,12 +49,12 @@ post-build:
cd ${WRKSRC}/doc/man; ${REINPLACE_CMD} \
-e 's:SYSCONFDIR:${PREFIX}/etc:g' \
-e 's:EXAMPLESDIR:${EXAMPLESDIR}:g' \
- ${MAN1} ${MAN5} ${WRKSRC}/doc/texinfo/${INFO:=.info}
+ nano.1 rnano.1 nanorc.5 ${WRKSRC}/doc/texinfo/${INFO:=.info}
${REINPLACE_CMD} -e 's/\\</[[:<:]]/g' -e 's/\\>/[[:>:]]/g' \
${WRKSRC}/doc/syntax/*.nanorc
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/nanorc.sample ${EXAMPLESDIR}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/nanorc.sample ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.post.mk>