aboutsummaryrefslogtreecommitdiffstats
path: root/editors
diff options
context:
space:
mode:
Diffstat (limited to 'editors')
-rw-r--r--editors/lazarus/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index 76bcc5744f9c..b4ea4b993e70 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -73,6 +73,8 @@ post-patch:
do-build:
@cd ${WRKSRC} && \
${SETENV} ${MAKE_ENV} ${GMAKE} LCL_PLATFORM=${LCL_PLATFORM}
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} tools LCL_PLATFORM=${LCL_PLATFORM}
post-build:
@cd ${WRKSRC} && \
@@ -119,7 +121,8 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/${DIRE}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/${DIRE}/{}" \;
.endfor
- @${CHMOD} +x ${DATADIR}/tools/svn2revisioninc
+ @${CHMOD} +x ${DATADIR}/tools/svn2revisioninc ${DATADIR}/tools/lazres ${DATADIR}/tools/lrstolfm \
+ ${DATADIR}/tools/updatepofiles
.for FILE in lazarus startlazarus lazbuild
${INSTALL_PROGRAM} ${WRKSRC}/${FILE} ${DATADIR}