aboutsummaryrefslogtreecommitdiffstats
path: root/emulators/virtualbox-ose/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'emulators/virtualbox-ose/Makefile')
-rw-r--r--emulators/virtualbox-ose/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 5126ebebfae4..4c8ffbafc754 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -120,6 +120,10 @@ OPTIONS_DEFAULT+= PYTHON
CONFLICTS_INSTALL+= virtualbox-ose-[0-9]*
.endif
+.if ${ARCH} == "amd64"
+_ELF32!= kldstat -q -m elf32 && echo yes || echo no
+.endif
+
.if ${PORT_OPTIONS:MNLS} && empty(PORT_OPTIONS:MQT[45])
BROKEN= NLS support requires QT frontend. Run 'make config' again!
.endif
@@ -241,7 +245,11 @@ CONFIGURE_ARGS+= --with-openssl-dir="${OPENSSLBASE}"
pre-everything::
.if ${ARCH} == "amd64"
-.if !exists(/usr/lib32/libc.so)
+.if ${_ELF32} != yes
+ @${ECHO} 'Requires 32-bit runtime support in kernel.'
+ @${ECHO} 'Rebuild kernel with "options COMPAT_FREEBSD32" and reboot.'
+ @${FALSE}
+.elif !exists(/usr/lib32/libc.so)
@${ECHO} 'Requires 32-bit libraries installed under /usr/lib32.'
@${ECHO} 'Do: cd /usr/src; make build32 install32; /etc/rc.d/ldconfig restart'
@${FALSE}