aboutsummaryrefslogtreecommitdiffstats
path: root/ftp/fastdfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ftp/fastdfs/Makefile')
-rw-r--r--ftp/fastdfs/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/ftp/fastdfs/Makefile b/ftp/fastdfs/Makefile
index ef7405f7f78f..b56e985abc97 100644
--- a/ftp/fastdfs/Makefile
+++ b/ftp/fastdfs/Makefile
@@ -1,13 +1,14 @@
# $FreeBSD$
PORTNAME= fastdfs
-PORTVERSION= 5.0.10
+PORTVERSION= 5.0.11
CATEGORIES= ftp
MAINTAINER= daniel@blodan.se
COMMENT= High performance distributed file system (DFS)
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING-3_0.txt
LIB_DEPENDS= libfastcommon.so:devel/libfastcommon
@@ -20,9 +21,9 @@ GROUPS= _fastdfs
USE_GITHUB= yes
GH_ACCOUNT= happyfish100
-GH_TAGNAME= bcb7c56
+GH_TAGNAME= 1e50b4f
-MAKE_ENV+= DESTDIR=${STAGEDIR}
+MAKE_ENV+= DESTDIR=${STAGEDIR}
do-build:
cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} ${SH} make.sh
1494b2f'>Convert LIB_DEPENDS for ports depending on boostbapt2013-12-121-14/+14 * In preparation for making libtool generate libraries with a sane name, fix allbapt2013-12-1121-64/+64 * - Update devel/tbb to 4.2.2martymac2013-12-111-0/+1 * - Update to 2.0.0rc3makc2013-12-116-123/+144 * Update to 0.9.7.zeising2013-12-113-6/+6 * - Fix build, adjust stagingnemysis2013-12-103-17/+9 * - Respect CMAKE_BUILD_TYPEmakc2013-12-052-19/+2 * Register conflicts with texlive-base-* since it has one file in common.mr2013-12-021-0/+2 * - Update from 2.3.0a4 to 2.3.2a3danilo2013-11-302-3/+3 * - Update to version 4.2pawel2013-11-234-21/+20 * Use gcc for now.mr2013-11-221-0/+3 * - Convert to USES=qmake (and other USES while I'm here)makc2013-11-225-56/+39 * Deprecated ports broken for more than 6 monthbapt2013-11-223-0/+9 * - Remove now needless qmake_build from USE_QT4makc2013-11-211-2/+2 * - Update to 7.5.233gahr2013-11-193-14/+18 * - USES dos2unix instead of USE_DOS2UNIXnemysis2013-11-191-2/+2 * - Add USE_DOS2UNIXnemysis2013-11-192-21/+37 * cad/feappv: Fix CFLAGS supportmarino2013-11-181-0/+13 * - Add a patches sent upstream and adjust the build flags to build withrakuco2013-11-185-164/+734 * Update qcad to 3.4.2.0mr2013-11-066-40/+169 * Welcome CMake 2.8.12!rakuco2013-11-062-0/+97 * cad/geda: update to 1.8.2wg2013-11-023-27/+39 * - Update from 2.2.0b3 to 2.3.0a4danilo2013-11-023-28/+19 * - Update to version 2.6.1pawel2013-11-024-41/+103 * The 0.3 version brings more electrical elements, more translations,vg2013-11-015-188/+2252 * - Fix run-time segmentation fault [1]gahr2013-11-0113-41/+128 * Update to libmpc version 1.0.1 which brings the following fixes:gerald2013-10-2617-11/+17 * Avoid to download the boost library during the build.mr2013-10-245-11/+66 * Try to fix build on current.mr2013-10-231-0/+10 * - Remove manual creation and removal of share/applications, as it's now in th...amdmi32013-10-2216-18/+1 * - Update from 3.7.52 to 3.7.54danilo2013-10-222-3/+3 * Update to 2.2.5antoine2013-10-152-19/+24 * Update to 3.3.3.0mr2013-10-124-127/+369 * Apply fixes provided by Maxmr2013-10-101-26/+21 * Try to fix the build.mr2013-10-101-11/+10 * - Convert to USES= qmakemakc2013-10-091-11/+8 * cad/varkon: Hardcode PLATFORM to "FreeBSD"marino2013-10-071-2/+2 * - Change maintainer email to @FreeBSD.orgdanilo2013-10-063-27/+23 * Removed dependency on gwavebapt2013-10-051-9/+3 * Remove the EOLed x11-toolkits/guile-gtk (gnome1) and its latest userbapt2013-10-057-159/+0 * The FreeBSD graphics/x11 team proudly presentszeising2013-09-302-1/+2 * - Update to 2.8.3.stephen2013-09-284-31/+22 * - Fix on CURRENT [1]gahr2013-09-273-7/+23 * - Update from 3.7.51 to 3.7.52danilo2013-09-263-29/+17 * - Update from 9.7.81 to 9.7.82danilo2013-09-253-11/+8 * - Remove NO_STAGE as these have been tested to be safebdrewery2013-09-253-3/+0 * - Remove cad/tkgate: it segfaults on startup, and has been doing so for as longgahr2013-09-2521-2802/+0 * - Convert to USES+=tkgahr2013-09-231-2/+2 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-20103-205/+145 * - Remove last vestiges of MAKE_JOBS_SAFE knobak2013-09-201-2/+0 * - Unbreak on CURRENT by adding USE_GCC= yesgahr2013-09-181-0/+1 * Fix plistmr2013-09-182-2/+2 * Update to a newer snapshot.mr2013-09-185-141/+810 * - Update to 0.80.1nemysis2013-09-185-67/+50 * - Update to 201301nemysis2013-09-183-11/+60 * Convert to new perl frameworkbapt2013-09-171-5/+2 * - Set make_jobs_unsafe.stephen2013-09-161-0/+2 * - convert to the new perl5 frameworkaz2013-09-131-2/+2 * Add explicit dependency on pkgconf (11 ports)marino2013-09-121-5/+2 * Add GLU to the build dependenciesmr2013-09-111-0/+1 * cad/ldraw: Mark BROKEN, checksum mismatchmarino2013-09-101-0/+1 * - convert to the new perl5 frameworkaz2013-09-101-6/+3 * - Use single space after WWW:sunpoet2013-09-081-1/+1 * cad/freehdl: fix build with clangwg2013-09-066-1/+92 * cad/irsim: update to 9.7.81wg2013-09-062-18/+14 * Add an explicit dependency on pkgconfbapt2013-09-051-2/+1 * Introduce ICONV_CONFIGURE_ARG variable defined at Uses/iconv.mk.bsam2013-09-051-1/+1 * cad/repsnapper: update to 2.2.0b3wg2013-09-042-4/+4 * Add two more dependencies.mr2013-09-041-2/+2 * Add an explicit dependency on pkgconfbapt2013-09-032-7/+3 * Add an explicit dependency on pkgconfbapt2013-09-032-5/+3 * Add an explicit dependency on pkgconfbapt2013-09-032-11/+4 * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 * Add an explicit dependency on pkgconfbapt2013-09-031-1/+1 * Add an explicit dependency on pkgconfbapt2013-09-031-2/+1 * Fix a hidden USE_GNOME=pkgconfigbapt2013-09-031-9/+3 * cad/repsnapper: update to 2.2.0b2wg2013-09-022-24/+23 * Add an explicit dependency on pkgconfigbapt2013-09-021-1/+1 * Add moc to the dependencies to fix the build.mr2013-08-291-1/+1 * Now metis-edf is selectable.maho2013-08-271-1/+11 * - Update to version from 12 August 2013danfe2013-08-253-27/+19 * Readd qcad and upgrade to version 3.2.1mr2013-08-2117-0/+10303 * Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.gerald2013-08-182-2/+2 * update to 2.6.1maho2013-08-167-58/+199 * - Remove MAKE_JOBS_SAFE variableak2013-08-1521-21/+0 * - update libdg to 2.1.0dinoex2013-08-092-2/+2 * - Update to 2.8.2.stephen2013-08-053-6/+11 * - Convert to new perl frameworkmat2013-08-034-8/+8 * Mark as broken: does not configure on any support versionbapt2013-07-291-4/+3 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-2731-1545/+0 * Change maintainership from @ports to new maintainer. From thedeischen2013-07-273-32/+69 * cad/pdnmesh: Specify libmath explicitly to linker to unbreak build.marino2013-07-241-4/+1 * - Make graphics/togl's libraries location independent from the Tcl/Tk versiongahr2013-07-241-3/+2 * Mark as broken, does not buildbapt2013-07-241-0/+2 * - Changed my emailvg2013-07-221-1/+1 * - Update to 1.0.3makc2013-07-203-24/+42 * - Update to 3.7.51miwi2013-07-172-3/+3 * cad/pcb: unbreak after USES= gmakemarino2013-07-151-1/+1 * - Update to 4.1madpilot2013-07-134-13/+17 * Mark as job unsafebapt2013-07-131-1/+2 * Mark jobs unsafebapt2013-07-121-6/+4 * Mark jobs unsafebapt2013-07-101-0/+1 * Convert from USE_MOTIF to USES=motifbapt2013-07-105-19/+11 * - Remove optional dependency on deprecated QT3rene2013-07-031-13/+3 * Fix installation when DRAW is not selected.thierry2013-07-031-1/+1 * cad/electric-ng: update to 9.0.4wg2013-06-233-18/+20 * Update to 3.3.47.zeising2013-06-232-4/+4 * Update to version 7.24.0pawel2013-06-224-2082/+2416 * cad/openvsp: update to 2.2.4wg2013-06-182-7/+6 * cad/ngspice_rework: update to 25wg2013-06-1310-120/+163 * - Trim headermiwi2013-06-121-5/+1 * Update to 3.7.50.rakuco2013-06-122-3/+3 * - Fix i18n manpagesmiwi2013-06-111-0/+4 * - Update to 4.0.hrs2013-06-014-17/+58