aboutsummaryrefslogtreecommitdiffstats
path: root/ftp
diff options
context:
space:
mode:
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 12e4c063305f..712c27d2fdba 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -162,14 +162,15 @@ IGNORE= only supports LDAPS with SSL
IGNORE= only supports LIBSSH2 with OpenSSL
.endif
-.if ${PORT_OPTIONS:MOPENSSL} && ( \
- defined(WITH_OPENSSL_PORT) || \
- (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so)) || \
- (defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"))
-.if ${PORT_OPTIONS:MGSSAPI_BASE}
-IGNORE= GSSAPI_BASE is set, which is not compatible with OpenSSL/LibreSSL from ports. Set GSSAPI_NONE or do not use ports SSL.
+.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL} && (defined(WITH_OPENSSL_PORT) || (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so)))
+IGNORE= GSSAPI_BASE is not compatible with OpenSSL from ports. Use other GSSAPI options or OpenSSL from base system
.endif
-.if ${PORT_OPTIONS:MTLS_SRP} && defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+
+.if defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL}
+IGNORE= GSSAPI_BASE is not compatible with LibreSSL. Use other GSSAPI options
+.endif
+.if ${PORT_OPTIONS:MTLS_SRP}
IGNORE= unsupported TLS-SRP in LibreSSL
.endif
.endif