aboutsummaryrefslogtreecommitdiffstats
path: root/games/4stattack
diff options
context:
space:
mode:
Diffstat (limited to 'games/4stattack')
-rw-r--r--games/4stattack/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/games/4stattack/Makefile b/games/4stattack/Makefile
index ae6366aeac42..b3918cc66076 100644
--- a/games/4stattack/Makefile
+++ b/games/4stattack/Makefile
@@ -12,19 +12,22 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Connect four stones in a straight line
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/GPL
RUN_DEPENDS= ${PYGAME}
USES= python
+NO_ARCH= yes
PORTDOCS= changelog.txt credits.txt
-OPTIONS_DEFINE= DOCS
INSTALLS_ICONS= yes
ICON_SIZES= 16x16 22x22 32x32 48x48 64x64
SUB_FILES= ${PORTNAME} pkg-message
+OPTIONS_DEFINE= DOCS
+
post-patch:
.for s in 16 22 32 48 64
@cd ${WRKSRC}/kde/icons/${s}x${s} ; \
@@ -56,6 +59,7 @@ do-install:
${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps/
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}