aboutsummaryrefslogtreecommitdiffstats
path: root/games/adonthell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/adonthell/Makefile')
-rw-r--r--games/adonthell/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 8a3e6edfe5c9..c0cbd9f62261 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -4,6 +4,7 @@
PORTNAME= adonthell
PORTVERSION= 0.3.8
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SAVANNAH
DISTFILES= ${PORTNAME}-src-${PORTVERSION}${EXTRACT_SUFX}
@@ -18,12 +19,13 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
-USES= gettext gmake localbase pkgconfig python:2.7 sdl
+USES= gettext gmake localbase pkgconfig python sdl
USE_SDL= mixer2 ttf2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-py-debug --disable-pyc \
- --with-python=${PYTHON_CMD} \
- --with-py-libs="-lpython${PYTHON_VER}"
+CONFIGURE_ARGS= --disable-py-debug \
+ --disable-pyc \
+ --with-py-libs="$$(${PYTHON_CMD}-config --ldflags)" \
+ --with-python=${PYTHON_CMD}
PLIST_DIRS= ${DATADIR}/games
PLIST_FILES= bin/adonthell \