aboutsummaryrefslogtreecommitdiffstats
path: root/games/dopewars/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/dopewars/Makefile')
-rw-r--r--games/dopewars/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/dopewars/Makefile b/games/dopewars/Makefile
index 6dd885647511..66f1410b1c91 100644
--- a/games/dopewars/Makefile
+++ b/games/dopewars/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= dopewars
-PORTVERSION= 1.5.3
+PORTVERSION= 1.5.4
CATEGORIES= games
MASTER_SITES= http://dopewars.sourceforge.net/ \
http://bellatrix.pcl.ox.ac.uk/~ben/dopewars/
-
MAINTAINER= petef@FreeBSD.org
USE_GMAKE= yes
@@ -33,5 +32,8 @@ post-patch:
${WRKSRC}/src/Makefile.in
@${PERL} -pi -e 's!dopewars.sco!dopewars/dopewars.sco!g' \
${WRKSRC}/src/dopewars.c ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's!^CFLAGS =!CFLAGS = \@GLIB_CFLAGS\@!' \
+ ${WRKSRC}/src/gui_client/Makefile.in \
+ ${WRKSRC}/src/curses_client/Makefile.in
.include <bsd.port.mk>