aboutsummaryrefslogtreecommitdiffstats
path: root/games/fgfs-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/fgfs-base/Makefile')
-rw-r--r--games/fgfs-base/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/games/fgfs-base/Makefile b/games/fgfs-base/Makefile
deleted file mode 100644
index 088bb5269551..000000000000
--- a/games/fgfs-base/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: flightgear
-# Date created: 26 June 1999
-# Whom: Brian Buchanan <brian@CSUA.Berkeley.EDU>
-#
-# $FreeBSD$
-#
-
-PORTNAME= fgfs-base
-PORTVERSION= 1.0.0
-CATEGORIES= games
-# see http://www.flightgear.org/templates.js
-MASTER_SITES= ftp://ftp.flightgear.org/pub/fgfs/Shared/ \
- ftp://ftp.de.flightgear.org/pub/fgfs/Shared/ \
- ftp://ftp.kingmont.com/flightsims/flightgear/Shared/ \
- ftp://ftp.linux.kiev.ua/pub/mirrors/ftp.flightgear.org/flightgear/Shared/ \
- http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/ \
- http://ftp3.linux.kiev.ua/pub/fgfs/Shared/
-
-MAINTAINER= ganael.laplanche@martymac.com
-COMMENT= FlightGear scenery, textures and aircraft models
-
-NO_BUILD= yes
-USE_BZIP2= yes
-WRKSRC= ${WRKDIR}/data
-DATADIR= ${PREFIX}/share/FlightGear
-
-PLIST= ${WRKDIR}/pkg-plist
-PLIST_DIRS= %%DATADIR%%
-
-post-patch:
- @${RM} -f ${WRKSRC}/COPYING ${WRKSRC}/Aircraft/A-10/COPYING ${WRKSRC}/Aircraft/787/COPYING
-
-pre-install:
- @${RM} -f ${PLIST}
- @cd ${WRKSRC} && \
- ${FIND} * -type d -empty | ${SORT} \
- | ${SED} -e 's|^|@exec ${MKDIR} %%DATADIR%%/|' >> ${PLIST} && \
- ${FIND} * -type f | ${SORT} \
- | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
- ${FIND} * -type d | ${SORT} -r \
- | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
-
-do-install:
- ${MKDIR} ${DATADIR}
- (cd ${WRKSRC}/ && ${COPYTREE_SHARE} \* ${DATADIR})
-
-.include <bsd.port.mk>