aboutsummaryrefslogtreecommitdiffstats
path: root/games/freebsd-games/files/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/freebsd-games/files/Makefile')
-rw-r--r--games/freebsd-games/files/Makefile37
1 files changed, 0 insertions, 37 deletions
diff --git a/games/freebsd-games/files/Makefile b/games/freebsd-games/files/Makefile
deleted file mode 100644
index ca13bede5c11..000000000000
--- a/games/freebsd-games/files/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# $FreeBSD$
-.include "Makefile.inc"
-
-GAMES= adventure arithmetic atc backgammon battlestar bs canfield cribbage \
- fish hack hangman larn mille phantasia piano pig quiz robots rogue \
- sail snake trek worm wump
-all: ${GAMES}
-.for I in ${GAMES}
- cd ${I} && make depend && make all
-.endfor
-
-install: ${GAMES}
- mtree -deU -f var.mtree -p ${VARDIR}
- mtree -deU -f share.mtree -p ${SHAREDIR}
-.for I in ${GAMES}
- cd ${I} && make install
-.endfor
-
-clean: ${GAMES}
-.for I in ${GAMES}
- cd ${I} && make clean
-.endfor
-
-extract: ${GAMES}
-
-.for I in ${GAMES}
-${I}:
- cvs -d `pwd`/cvs get ${I}
-.endfor
-
-commit:
-.for I in ${GAMES}
- cvs -d `pwd`/cvs commit -F ./commitmsg ${I}
-.endfor
-
-distclean:
- rm -rf ${GAMES}