aboutsummaryrefslogtreecommitdiffstats
path: root/games/kuklomenos
diff options
context:
space:
mode:
Diffstat (limited to 'games/kuklomenos')
-rw-r--r--games/kuklomenos/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/games/kuklomenos/Makefile b/games/kuklomenos/Makefile
index 68ab2a4951dc..17162234a95b 100644
--- a/games/kuklomenos/Makefile
+++ b/games/kuklomenos/Makefile
@@ -17,7 +17,8 @@ LICENSE= GPLv3
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
-OPTIONS= VORBIS "Enable Ogg/Vorbis support" on
+OPTIONS_DEFINE= VORBIS
+OPTIONS_DEFAULT= VORBIS
USE_SDL= sdl
GNU_CONFIGURE= yes
@@ -28,12 +29,12 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.options.mk>
-.if defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+=--disable-sound
-PLIST_SUB+= VORBIS="@comment "
-.else
+.if ${PORT_OPTIONS:MVORBIS}
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
PLIST_SUB+= VORBIS=""
+.else
+CONFIGURE_ARGS+=--disable-sound
+PLIST_SUB+= VORBIS="@comment "
.endif
post-patch: