aboutsummaryrefslogtreecommitdiffstats
path: root/games/megaglest/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/megaglest/Makefile')
-rw-r--r--games/megaglest/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 72d6b9f84a90..c1266436bae7 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -6,32 +6,35 @@
#
PORTNAME= megaglest
-PORTVERSION= 3.5.2
-PORTREVISION= 3
+PORTVERSION= 3.6.0.3
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/current_release/
-DISTNAME= ${PORTNAME}-source-${PORTVERSION}.3
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}_${PORTVERSION}/
+DISTNAME= ${PORTNAME}-source-${PORTVERSION}
-MAINTAINER= smoeller@nichthelfer.de
+MAINTAINER= rnejdl@ringofsaturn.com
COMMENT= Open source 3D real-time strategy game
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
+ ftgl.2:${PORTSDIR}/graphics/ftgl \
vorbis.4:${PORTSDIR}/audio/libvorbis
-RUN_DEPENDS= ${DATADIR}/tutorials/basic_tutorial/basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
+BUILD_DEPENDS= ${LOCALBASE}/include/libircclient.h:${PORTSDIR}/irc/libircclient \
+ ${LOCALBASE}/include/miniupnpc/miniupnpc.h:${PORTSDIR}/net/miniupnpc
+RUN_DEPENDS= ${DATADIR}/tutorials/2_basic_tutorial/2_basic_tutorial.xml:${PORTSDIR}/games/megaglest-data
SUB_FILES= pkg-message
USE_XZ= yes
USE_CMAKE= yes
USE_DOS2UNIX= yes
-USE_GL= yes
+USE_GL= glew gl glu
USE_LUA= 5.1
USE_OPENAL= al alut
USE_SDL= yes
USE_WX= 2.8+
+MAKE_JOBS_SAFE= yes
CFLAGS+= -I${LOCALBASE}/include/libpng15
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}