aboutsummaryrefslogtreecommitdiffstats
path: root/games/tome4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tome4/Makefile')
-rw-r--r--games/tome4/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index 7fa6215aaf42..377be4b4216e 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tome4
PORTVERSION= 1.1.5
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://te4.org/dl/t-engine/ \
SF/lifanov-ports-icons/${PORTNAME}/:icons
@@ -18,8 +19,8 @@ LICENSE= GPLv3
BUILD_DEPENDS= premake4:${PORTSDIR}/devel/premake4
LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis
-DESKTOP_ENTRIES="ToME 4" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;RolePlaying;" false
+DESKTOP_ENTRIES="ToME 4" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;RolePlaying;" ""
WRKSRC= ${WRKDIR}/t-engine4-src-${PORTVERSION}
MAKE_ARGS+= config=release verbose=yes ARCH=""
@@ -27,19 +28,17 @@ USES= gmake openal:al tar:bzip2
USE_SDL= image2 sdl2 ttf2
USE_GL= gl
SUB_FILES= tome4
-
MAKE_JOBS_UNSAFE=yes
pre-build:
- (cd ${WRKSRC}; premake4 gmake)
+ (cd ${WRKSRC} && premake4 gmake)
@${REINPLACE_CMD} 's|-lpthread|-pthread|' ${WRKSRC}/build/TEngine.make
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${WRKSRC}/t-engine ${STAGEDIR}${DATADIR}
- ${INSTALL} -m 0755 ${WRKDIR}/tome4 ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL} -m 0755 ${WRKDIR}/tome4 ${STAGEDIR}${PREFIX}/bin/
(cd ${WRKSRC}; ${COPYTREE_SHARE} "bootstrap game" ${STAGEDIR}${DATADIR})
${INSTALL_DATA} ${_DISTDIR}/${PORTNAME}.png \