aboutsummaryrefslogtreecommitdiffstats
path: root/games/uhexen2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/uhexen2/Makefile')
-rw-r--r--games/uhexen2/Makefile145
1 files changed, 76 insertions, 69 deletions
diff --git a/games/uhexen2/Makefile b/games/uhexen2/Makefile
index 8f0eedafee25..50311bbbd850 100644
--- a/games/uhexen2/Makefile
+++ b/games/uhexen2/Makefile
@@ -2,65 +2,48 @@
# $FreeBSD$
PORTNAME= uhexen2
-PORTVERSION= 1.5.1
-PORTREVISION= 1
+PORTVERSION= 1.5.6
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/Hammer%20of%20Thyrion/${PORTVERSION}/Source
+MASTER_SITES= SF/${PORTNAME}/Hammer%20of%20Thyrion/${PORTVERSION}/Source \
+ SF/${PORTNAME}/Hexen2%20GameData/gamedata-1.28:data
DISTNAME= hexen2source-${PORTVERSION}
EXTRACT_SUFX= .tgz
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ gamedata-all-1.28${EXTRACT_SUFX}:data
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Hexen II source port supporting Linux/FreeBSD/Unix/Windows
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-10
+LICENSE= GPLv2 # (or later)
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad
-
-LICENSE_= GPLv2 GPLv3
-LICENSE_COMB= dual
-
-USE_GMAKE= yes
-USE_GL= yes
-USE_SDL= sdl mixer
-WANT_GNOME= yes
-MAKE_JOBS_UNSAFE= yes
+LIB_DEPENDS= libmad.so:${PORTSDIR}/audio/libmad \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
OPTIONS_MULTI= BIN
OPTIONS_MULTI_BIN= HEXEN2 HW
-OPTIONS_DEFINE= DEMO LAUNCHER_GTK1 LAUNCHER_GTK2 X86_ASM DOCS
-OPTIONS_DEFAULT= HEXEN2 HW LAUNCHER_GTK1 X86_ASM
-DEMO_DESC= Install demo version of the game data
-HEXEN2_DESC= Build Hexen II clients and servers
-HW_DESC= Build HexenWorld clients and servers
+OPTIONS_DEFINE= LAUNCHER_GTK1 LAUNCHER_GTK2 LAUNCHER_GTK3 DOCS
+OPTIONS_DEFAULT= HEXEN2 HW LAUNCHER_GTK2
+OPTIONS_DEFINE_i386= ASM
+OPTIONS_DEFAULT_i386= ASM
+
+HEXEN2_DESC= Build Hexen II clients and servers
+HW_DESC= Build HexenWorld clients and servers
LAUNCHER_GTK1_DESC= Build graphical (GTK1) game launcher
LAUNCHER_GTK2_DESC= Build graphical (GTK2) game launcher
-X86_ASM_DESC= Enable use of optimized x86 assembly code
+LAUNCHER_GTK3_DESC= Build graphical (GTK3) game launcher
+
+USES= gmake pkgconfig
+USE_SDL= sdl
+USE_GL= gl
+MAKE_ENV= X11BASE="${LOCALBASE}"
+MAKE_JOBS_UNSAFE=yes
+
+SUB_FILES= pkg-message
PORTSCOUT= skipb:yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MDEMO}
-MASTER_SITES+= SF/${PORTNAME}/Hammer%20of%20Thyrion/${PORTVERSION}/Linux-demo-version:demo
-DISTFILES+= hexen2demo-${PORTVERSION}-linux-i586${EXTRACT_SUFX}:demo
-MAKE_ENV+= DEMO=yes
-PLIST_SUB+= DEMO="" \
- FULL="@comment "
-UH2_DATA= default.cfg hexen.rc pak0.pak progs.dat
-UH2_DATADIR= ${WRKDIR}/hexen2demo-${PORTVERSION}
-.else
-MASTER_SITES+= SF/${PORTNAME}/Hexen2%20GameData/gamedata-1.20:data
-DISTFILES+= gamedata-all-1.20${EXTRACT_SUFX}:data
-PLIST_SUB+= DEMO="@comment " \
- FULL=""
-SUB_FILES+= pkg-message
-UH2_DATA= default.cfg hexen.rc progs.dat progs2.dat strings.txt
-UH2_DATADIR= ${WRKDIR}
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MHEXEN2}
MAKE_ENV+= BUILD_HEXEN2=yes
@@ -72,15 +55,14 @@ PLIST_SUB+= HEXEN2="@comment "
.endif
.if ${PORT_OPTIONS:MHW}
-. if empty(PORT_OPTIONS:MDEMO)
MASTER_SITES+= SF/${PORTNAME}/Hexen2%20GameData/hexenworld-pakfiles:hw
DISTFILES+= hexenworld-pakfiles-0.15${EXTRACT_SUFX}:hw
-. endif
MAKE_ENV+= BUILD_HW=yes
PLIST_SUB+= HW=""
UH2_BIN+= engine/hexenworld/client/glhwcl \
+ engine/hexenworld/client/hwcl \
engine/hexenworld/server/hwsv \
- engine/hexenworld/client/hwcl
+ hw_utils/hwmaster/hwmaster
.else
PLIST_SUB+= HW="@comment "
.endif
@@ -101,46 +83,71 @@ PLIST_SUB+= LAUNCHER_GTK2=""
PLIST_SUB+= LAUNCHER_GTK2="@comment "
.endif
-.if ${PORT_OPTIONS:MX86_ASM} && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MLAUNCHER_GTK3}
+USE_GNOME+= gtk30
+MAKE_ENV+= BUILD_LAUNCHER_GTK3=yes
+PLIST_SUB+= LAUNCHER_GTK3=""
+.else
+PLIST_SUB+= LAUNCHER_GTK3="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MASM}
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
MAKE_ENV+= USE_X86_ASM=yes
+.else
+MAKE_ENV+= USE_X86_ASM=no
.endif
post-extract:
@${CP} ${FILESDIR}/${MAKEFILE} ${WRKSRC}
+post-patch:
+.for f in engine/hexen2/Makefile engine/hexenworld/client/Makefile \
+ engine/hexenworld/server/Makefile hw_utils/hwmaster/Makefile \
+ launcher/Makefile libs/timidity/Makefile
+ @${REINPLACE_CMD} -e \
+ '/^USE_X86_ASM/s|^|#| ; \
+ /^CPU_X86/s|^|#| ; \
+ /^CFLAGS/s| -g | | ; \
+ /^CFLAGS/s| -O2 | | ; \
+ /^PTHREAD_LIBS/s|-lpthread|-pthread|' ${WRKSRC}/${f}
+.endfor
+.for f in engine/h2shared/cd_bsd.c
+ @${REINPLACE_CMD} -e \
+ 's|"acd0"|"cd0"|' ${WRKSRC}/${f}
+.endfor
+.for f in engine/hexen2/sys_unix.c engine/hexenworld/client/sys_unix.c
+ @${REINPLACE_CMD} -e \
+ '/parms.basedir/s|= cwd;|= "${DATADIR}";|' ${WRKSRC}/${f}
+.endfor
+
do-install:
.for f in ${UH2_BIN}
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${MKDIR} ${DATADIR}/data1
-.for f in ${UH2_DATA}
- ${INSTALL_DATA} ${UH2_DATADIR}/data1/${f} ${DATADIR}/data1
+ ${MKDIR} ${STAGEDIR}${DATADIR}/data1
+.for f in default.cfg hexen.rc progs.dat progs2.dat strings.txt
+ ${INSTALL_DATA} ${WRKDIR}/data1/${f} ${STAGEDIR}${DATADIR}/data1
.endfor
-.if empty(PORT_OPTIONS:MDEMO)
- ${INSTALL_DATA} ${WRKDIR}/patchdat/data1/* ${DATADIR}/data1
- ${CP} -R ${WRKDIR}/portals ${DATADIR}
-.endif
+ ${INSTALL_DATA} ${WRKDIR}/patchdat/data1/* ${STAGEDIR}${DATADIR}/data1
+ @(cd ${WRKDIR} && ${COPYTREE_SHARE} portals ${STAGEDIR}${DATADIR})
.if ${PORT_OPTIONS:MHW}
- ${MKDIR} ${DATADIR}/hw
- ${INSTALL_DATA} ${UH2_DATADIR}/hw/* ${DATADIR}/hw
+ ${MKDIR} ${STAGEDIR}${DATADIR}/hw
+ ${INSTALL_DATA} ${WRKDIR}/hw/* ${STAGEDIR}${DATADIR}/hw
.endif
.if ${PORT_OPTIONS:MLAUNCHER_GTK1}
- ${INSTALL_PROGRAM} ${WRKSRC}/launcher/h2launcher.gtk1 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/launcher/h2launcher.gtk1 \
+ ${STAGEDIR}${PREFIX}/bin
.endif
.if ${PORT_OPTIONS:MLAUNCHER_GTK2}
- ${INSTALL_PROGRAM} ${WRKSRC}/launcher/h2launcher.gtk2 ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/launcher/h2launcher.gtk2 \
+ ${STAGEDIR}${PREFIX}/bin
.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
-.endif
-
-.if empty(PORT_OPTIONS:MDEMO)
-post-install:
- @${ECHO_CMD}
- @${CAT} ${PKGMESSAGE}
- @${ECHO_CMD}
+.if ${PORT_OPTIONS:MLAUNCHER_GTK3}
+ ${INSTALL_PROGRAM} ${WRKSRC}/launcher/h2launcher.gtk3 \
+ ${STAGEDIR}${PREFIX}/bin
.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>