aboutsummaryrefslogtreecommitdiffstats
path: root/games/xcheckers/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xcheckers/Makefile')
-rw-r--r--games/xcheckers/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/xcheckers/Makefile b/games/xcheckers/Makefile
new file mode 100644
index 000000000000..1833568d6cfc
--- /dev/null
+++ b/games/xcheckers/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xcheckers
+# Date created: 25 January 2003
+# Whom: Simon Barner <barner@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcheckers
+PORTVERSION= 2.1
+CATEGORIES= games
+MASTER_SITES= http://arton.cunst.net/xcheckers/
+
+MAINTAINER= barner@gmx.de
+COMMENT= A checkers game for X11
+
+USE_IMAKE= yes
+USE_REINPLACE= yes
+
+MAN6= xcheckers.6 simplech.6
+
+# included by both imake and sh
+post-patch:
+ @${REINPLACE_CMD} '/^#/d' ${WRKSRC}/Local.config
+
+pre-install:
+ @${REINPLACE_CMD} 's:@X11BASE@:${X11BASE}:g' \
+ ${WRKSRC}/xcheckers.src/xcheckers.man
+
+.include <bsd.port.mk>