aboutsummaryrefslogtreecommitdiffstats
path: root/games/xjewel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/xjewel/Makefile')
-rw-r--r--games/xjewel/Makefile19
1 files changed, 5 insertions, 14 deletions
diff --git a/games/xjewel/Makefile b/games/xjewel/Makefile
index 627680faed38..9cf74c64bee3 100644
--- a/games/xjewel/Makefile
+++ b/games/xjewel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xjewel
PORTVERSION= 1.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= XCONTRIB/../R5contrib
EXTRACT_SUFX= .tar.z
@@ -11,25 +11,16 @@ EXTRACT_SUFX= .tar.z
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 dropping jewels game
-BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
- mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
-USES= imake
+USES= fonts imake
USE_XORG= x11 xext
-SUB_FILES= pkg-install pkg-deinstall
-SUB_LIST= FONTSDIR="${FONTSDIR}"
-
-PLIST_SUB= FONTSDIR="${FONTSDIR}"
-
DESKTOP_ENTRIES="XJewel" "" "" "${PORTNAME}" "" ""
-FONTSDIR= lib/X11/fonts/local
-
post-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
(cd ${WRKSRC}/bitmaps && ${INSTALL_DATA} seven_seg.pcf.gz \
- ${STAGEDIR}${PREFIX}/${FONTSDIR})
+ ${STAGEDIR}${FONTSDIR})
.include <bsd.port.mk>