aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/0ad/Makefile2
-rw-r--r--games/megaglest/Makefile1
-rw-r--r--games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp11
3 files changed, 13 insertions, 1 deletions
diff --git a/games/0ad/Makefile b/games/0ad/Makefile
index fb54f34a6904..219b6738cf7b 100644
--- a/games/0ad/Makefile
+++ b/games/0ad/Makefile
@@ -2,7 +2,7 @@
PORTNAME= 0ad
PORTVERSION= 0.0.21
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= http://releases.wildfiregames.com/ \
SF/zero-ad/releases
diff --git a/games/megaglest/Makefile b/games/megaglest/Makefile
index 3aea5f93c8ee..0a0e8353e843 100644
--- a/games/megaglest/Makefile
+++ b/games/megaglest/Makefile
@@ -3,6 +3,7 @@
PORTNAME= megaglest
PORTVERSION= 3.12.0
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= monwarez@mailoo.org
diff --git a/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp b/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp
new file mode 100644
index 000000000000..d50e6ae4cfe4
--- /dev/null
+++ b/games/megaglest/files/patch-source-shared_lib-sources-platform-posix-socket.cpp
@@ -0,0 +1,11 @@
+--- source/shared_lib/sources/platform/posix/socket.cpp.orig 2016-12-26 00:02:43.325573000 +0100
++++ source/shared_lib/sources/platform/posix/socket.cpp 2016-12-26 00:04:06.681172000 +0100
+@@ -2632,7 +2632,7 @@
+
+ //printf("UPnP device found: [%s] [%s] lanaddr [%s]\n", dev->descURL, dev->st,lanaddr);
+ #if (defined(MINIUPNPC_API_VERSION) && MINIUPNPC_API_VERSION >= 9) || (!defined(MINIUPNPC_VERSION_PRE1_7) && !defined(MINIUPNPC_VERSION_PRE1_6))
+- char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])),0);
++ char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])),0,0);
+ #else
+ char *descXML = (char *)miniwget_getaddr(dev->descURL, &descXMLsize, lanaddr, (sizeof(lanaddr) / sizeof(lanaddr[0])));
+ #endif