aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/abridge/Makefile5
-rw-r--r--games/blokish/Makefile5
-rw-r--r--games/scorched3d/Makefile13
3 files changed, 9 insertions, 14 deletions
diff --git a/games/abridge/Makefile b/games/abridge/Makefile
index 8b3cb5fc3d10..70fd14ee4cfa 100644
--- a/games/abridge/Makefile
+++ b/games/abridge/Makefile
@@ -14,10 +14,9 @@ MASTER_SITES= http://www.abridgegame.org/src/
MAINTAINER= Janos.Mohacsi@bsd.hu
COMMENT= Bridge game
-LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk24
-
+USE_WX= 2.4
+WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-wx-config=${X11BASE}/bin/wxgtk2-2.4-config
MAN1= abridge.1
PLIST_FILES= bin/abridge
diff --git a/games/blokish/Makefile b/games/blokish/Makefile
index 0db03e3522c4..c1aed4dcda3c 100644
--- a/games/blokish/Makefile
+++ b/games/blokish/Makefile
@@ -16,12 +16,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= amdmi3@mail.ru
COMMENT= Clone of the strategy board game 'Blokus'
-LIB_DEPENDS= wx_base-2.6.0:${PORTSDIR}/x11-toolkits/wxgtk26
-
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GL= yes
+USE_WX= 2.6
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
@@ -39,6 +38,6 @@ EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-ai.h
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|wx-config|wxgtk2-2.6-config|' ${WRKSRC}/makefile.in ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|' ${WRKSRC}/makefile.in ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 0cc273797b07..4275969461a0 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -15,12 +15,8 @@ DISTNAME= Scorched3D-${SCORCH_VERSION}-src
MAINTAINER= guy@device.dyndns.org
COMMENT= Scorched is a game based loosely on the classic DOS game
-BUILD_DEPENDS= ${X11BASE}/include/wx-2.6/wx/wx.h:${PORTSDIR}/x11-toolkits/wxgtk26-common \
- wxgtk2-2.6-config:${PORTSDIR}/x11-toolkits/wxgtk26 \
- openal-config:${PORTSDIR}/audio/openal
-RUN_DEPENDS= ${X11BASE}/include/wx-2.6/wx/wx.h:${PORTSDIR}/x11-toolkits/wxgtk26-common \
- wxgtk2-2.6-config:${PORTSDIR}/x11-toolkits/wxgtk26 \
- openal-config:${PORTSDIR}/audio/openal
+BUILD_DEPENDS= openal-config:${PORTSDIR}/audio/openal
+RUN_DEPENDS= openal-config:${PORTSDIR}/audio/openal
LIB_DEPENDS= alut.1:${PORTSDIR}/audio/freealut
SCORCH_VERSION= 40.1d
@@ -33,13 +29,14 @@ GNU_CONFIGURE= yes
USE_GL= yes
USE_GMAKE= yes
USE_AUTOTOOLS= automake:15 autoconf:253
+USE_WX= 2.6
+WX_CONF_ARGS= absolute
WRKSRC= ${WRKDIR}/scorched
AUTOMAKE_ARGS= --foreign
CONFIGURE_ARGS= --program-prefix='' \
--prefix=${PREFIX}/games/scorched3d \
- --datadir=${PREFIX}/games/scorched3d \
- --with-wx-config=${X11BASE}/bin/wxgtk2-2.6-config
+ --datadir=${PREFIX}/games/scorched3d
.if defined(WITH_MYSQL)
CONFIGURE_ARGS+= --with-mysql
.endif