aboutsummaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/stonesoup/Makefile4
-rw-r--r--games/stonesoup/files/patch-Makefile4
-rw-r--r--games/warzone2100/Makefile2
-rw-r--r--games/xblast/Makefile4
-rw-r--r--games/xjewel/Makefile19
-rw-r--r--games/xjewel/files/pkg-deinstall.in13
-rw-r--r--games/xjewel/files/pkg-install.in12
-rw-r--r--games/xmoto/Makefile6
-rw-r--r--games/xpacman/Makefile2
9 files changed, 16 insertions, 50 deletions
diff --git a/games/stonesoup/Makefile b/games/stonesoup/Makefile
index fb2251d7a092..c356e2c78903 100644
--- a/games/stonesoup/Makefile
+++ b/games/stonesoup/Makefile
@@ -58,8 +58,8 @@ MAKE_ARGS+= TILES=y
PLIST_SUB+= SDL=""
PKGNAMESUFFIX= -sdl
BUILD_DEPENDS+= fc-list:${PORTSDIR}/x11-fonts/fontconfig \
- ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
-RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+ ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+RUN_DEPENDS+= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
USE_SDL= sdl image
diff --git a/games/stonesoup/files/patch-Makefile b/games/stonesoup/files/patch-Makefile
index 30a8a7800833..de953b0b10d1 100644
--- a/games/stonesoup/files/patch-Makefile
+++ b/games/stonesoup/files/patch-Makefile
@@ -78,7 +78,7 @@
endif
else
- SYS_PROPORTIONAL_FONT = $(shell dir=/usr/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
-+ SYS_PROPORTIONAL_FONT = $(shell dir=%%LOCALBASE%%/lib/X11/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
++ SYS_PROPORTIONAL_FONT = $(shell dir=%%LOCALBASE%%/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
ifeq (,$(SYS_PROPORTIONAL_FONT))
SYS_PROPORTIONAL_FONT = $(shell dir=/usr/local/share/fonts ; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
endif
@@ -87,7 +87,7 @@
endif
else
- SYS_MONOSPACED_FONT = $(shell dir=/usr/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
-+ SYS_MONOSPACED_FONT = $(shell dir=%%LOCALBASE%%/lib/X11/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
++ SYS_MONOSPACED_FONT = $(shell dir=%%LOCALBASE%%/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
ifeq (,$(SYS_MONOSPACED_FONT))
SYS_MONOSPACED_FONT = $(shell dir=/usr/local/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
endif
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index 71aaf3729053..635dbeccac3c 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libphysfs.so:${PORTSDIR}/devel/physfs \
libfribidi.so:${PORTSDIR}/converters/fribidi \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
-RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
+RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans.ttf:${PORTSDIR}/x11-fonts/dejavu
USES= tar:xz bison gmake openal:al pkgconfig compiler:c++11-lang # actually, old gcc fails on unknown -W flag
GNU_CONFIGURE= yes
diff --git a/games/xblast/Makefile b/games/xblast/Makefile
index 0672c428d200..bbc2f6c4b50c 100644
--- a/games/xblast/Makefile
+++ b/games/xblast/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xblast
PORTVERSION= 2.10.4
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION} \
SF/${PORTNAME}/Images/${IMAGES_DATE}:images \
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= --with-otherdatadir=${DATADIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-FONTSDIR= ${LOCALBASE}/lib/X11/fonts/bitstream-vera
+FONTSDIR= ${LOCALBASE}/share/fonts/bitstream-vera
IMAGES_DATE= 2005-01-06
LEVELS_DATE= 2005-01-06
diff --git a/games/xjewel/Makefile b/games/xjewel/Makefile
index 627680faed38..9cf74c64bee3 100644
--- a/games/xjewel/Makefile
+++ b/games/xjewel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xjewel
PORTVERSION= 1.6
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= XCONTRIB/../R5contrib
EXTRACT_SUFX= .tar.z
@@ -11,25 +11,16 @@ EXTRACT_SUFX= .tar.z
MAINTAINER= ports@FreeBSD.org
COMMENT= X11 dropping jewels game
-BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf \
- mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
- mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
+BUILD_DEPENDS= bdftopcf:${PORTSDIR}/x11-fonts/bdftopcf
-USES= imake
+USES= fonts imake
USE_XORG= x11 xext
-SUB_FILES= pkg-install pkg-deinstall
-SUB_LIST= FONTSDIR="${FONTSDIR}"
-
-PLIST_SUB= FONTSDIR="${FONTSDIR}"
-
DESKTOP_ENTRIES="XJewel" "" "" "${PORTNAME}" "" ""
-FONTSDIR= lib/X11/fonts/local
-
post-install:
+ @${MKDIR} ${STAGEDIR}${FONTSDIR}
(cd ${WRKSRC}/bitmaps && ${INSTALL_DATA} seven_seg.pcf.gz \
- ${STAGEDIR}${PREFIX}/${FONTSDIR})
+ ${STAGEDIR}${FONTSDIR})
.include <bsd.port.mk>
diff --git a/games/xjewel/files/pkg-deinstall.in b/games/xjewel/files/pkg-deinstall.in
deleted file mode 100644
index 5acdd065022e..000000000000
--- a/games/xjewel/files/pkg-deinstall.in
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-
-if [ "x$2" = "xPOST-DEINSTALL" ]; then
- cd ${PKG_PREFIX}/%%FONTSDIR%%; ${PKG_PREFIX}/bin/mkfontdir
- ${PKG_PREFIX}/bin/xset fp rehash ||
- (
- echo "**********************************************************"
- echo "You should restart X server or do 'xset fp rehash' command"
- echo "to enable this update."
- echo "**********************************************************"
- )
- [ `wc -c ${PKG_PREFIX}/%%FONTSDIR%%/fonts.dir | awk '{print $1}'` = 2 ] && rm -f ${PKG_PREFIX}/%%FONTSDIR%%/fonts.dir
-fi
diff --git a/games/xjewel/files/pkg-install.in b/games/xjewel/files/pkg-install.in
deleted file mode 100644
index 77be2d3b8f9e..000000000000
--- a/games/xjewel/files/pkg-install.in
+++ /dev/null
@@ -1,12 +0,0 @@
-#!/bin/sh
-
-if [ "x$2" = "xPOST-INSTALL" ]; then
- cd ${PKG_PREFIX}/%%FONTSDIR%%; ${PKG_PREFIX}/bin/mkfontdir
- ${PKG_PREFIX}/bin/xset fp rehash ||
- (
- echo "**********************************************************"
- echo "You should restart X server or do 'xset fp rehash' command"
- echo "to enable this update."
- echo "**********************************************************"
- )
-fi
diff --git a/games/xmoto/Makefile b/games/xmoto/Makefile
index 33ec6e1974cf..ff0a1104791e 100644
--- a/games/xmoto/Makefile
+++ b/games/xmoto/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmoto
PORTVERSION= 0.5.11
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= http://download.tuxfamily.org/xmoto/xmoto/${PORTVERSION}/ \
http://mirror.amdmi3.ru/distfiles/
@@ -42,8 +42,8 @@ OPTIONS_SUB= yes
ASIAN_TTF_DESC= Use asian TTF font
-ASIAN_TTF_RUN_DEPENDS= ${LOCALBASE}/lib/X11/fonts/TrueType/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
-ASIAN_TTF_CONFIGURE_ON= --with-asian-ttf-file=${LOCALBASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf
+ASIAN_TTF_RUN_DEPENDS= ${LOCALBASE}/share/fonts/TrueType/bkai00mp.ttf:${PORTSDIR}/chinese/arphicttf
+ASIAN_TTF_CONFIGURE_ON= --with-asian-ttf-file=${LOCALBASE}/share/fonts/TrueType/bsmi00lp.ttf
ASIAN_TTF_CONFIGURE_OFF=--without-asian-ttf-file
NLS_USES= gettext
diff --git a/games/xpacman/Makefile b/games/xpacman/Makefile
index 1e6828affeda..9bfa383a873e 100644
--- a/games/xpacman/Makefile
+++ b/games/xpacman/Makefile
@@ -12,7 +12,7 @@ COMMENT= Old action game
LICENSE= GPLv2
-RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/misc/9x18.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
+RUN_DEPENDS+= ${LOCALBASE}/share/fonts/misc/9x18.pcf.gz:${PORTSDIR}/x11-fonts/font-misc-misc
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-doublesize