aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/aalib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/aalib/Makefile')
-rw-r--r--graphics/aalib/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/graphics/aalib/Makefile b/graphics/aalib/Makefile
index 055180fb3dae..1cb333fdd16c 100644
--- a/graphics/aalib/Makefile
+++ b/graphics/aalib/Makefile
@@ -8,29 +8,24 @@
PORTNAME= aalib
PORTVERSION= 1.2
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.ta.jcu.cz/pub/aa/
+MASTER_SITES= ftp://horac.ta.jcu.cz/pub/aa/
MAINTAINER= ports@FreeBSD.org
-USE_AUTOCONF= yes
+USE_AUTOMAKE= yes
+AUTOMAKE= automake -a -i
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-#
-# Support for X11 is compiled in by default only if X11 is installed.
-#
-.if defined(WITH_X11) || (exists(${X11BASE}/lib/libX11.a) \
- && !defined(WITHOUT_X11))
+.if defined(WITH_X11)
USE_XLIB= yes
-CONFIGURE_ARGS= --with-x --x-includes="${X11BASE}/include" \
+CONFIGURE_ARGS= --x-includes="${X11BASE}/include" \
--x-libraries="${X11BASE}/lib"
.else
-CONFIGURE_ARGS= --with-x11-driver=no
+CONFIGURE_ARGS= --with-x=no
.endif
post-patch:
- @${PERL} -pi -e "s:/usr/local:${LOCALBASE}:g;" ${WRKSRC}/configure.in
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}|g;" ${WRKSRC}/configure.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>