aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/dcmtk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dcmtk/Makefile')
-rw-r--r--graphics/dcmtk/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/dcmtk/Makefile b/graphics/dcmtk/Makefile
new file mode 100644
index 000000000000..d912e169cefe
--- /dev/null
+++ b/graphics/dcmtk/Makefile
@@ -0,0 +1,32 @@
+# Created by: gahr
+# $FreeBSD$
+
+PORTNAME= dcmtk
+DISTVERSIONPREFIX= ${PORTNAME:tu}-
+DISTVERSION= 3.6.4
+CATEGORIES= graphics devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DICOM ToolKit, libraries and applications for DICOM/MEDICOM standard
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+LIB_DEPENDS= libicuuc.so:devel/icu \
+ libpng16.so:graphics/png \
+ libtiff.so:graphics/tiff
+
+USES= cmake:outsource gnome jpeg ssl
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME:tu}
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+CMAKE_ON= BUILD_SHARED_LIBS
+CMAKE_OFF= DCMTK_WITH_DOXYGEN
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.mk>