aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/deegree-wfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/deegree-wfs/Makefile')
-rw-r--r--graphics/deegree-wfs/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/graphics/deegree-wfs/Makefile b/graphics/deegree-wfs/Makefile
index 2b7c6f2887cf..82b66087b9a0 100644
--- a/graphics/deegree-wfs/Makefile
+++ b/graphics/deegree-wfs/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: deegree-wfs
-# Date created: 17 April, 2009
-# Whom: wenheping@gmail.com
+# Created by: wenheping@gmail.com
#
# $FreeBSD$
-#
PORTNAME= wfs
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= http://download.deegree.org/deegree${PORTVERSION}/
PKGNAMEPREFIX= deegree-
@@ -15,13 +13,13 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}_${PORTVERSION}
MAINTAINER= wenheping@gmail.com
COMMENT= Deegree Web Feature Service(WFS)
-RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
+RUN_DEPENDS= ${LOCALBASE}/${TOMCATVER}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
USE_ZIP= yes
USE_JAVA= 1.5+
NO_BUILD= yes
-TOMCATVER= tomcat5.5
+TOMCATVER= apache-tomcat-6.0
TOMCATDIR= ${PREFIX}/${TOMCATVER}
WEBAPPDIR= ${TOMCATDIR}/webapps
PORTDOCS= *
@@ -32,12 +30,14 @@ post-extract:
@${MKDIR} ${WRKDIR}/${PORTDIRNAME}
@${TAR} xf ${WRKDIR}/deegree-wfs.war -C ${WRKDIR}/${PORTDIRNAME}
+.include <bsd.port.options.mk>
+
do-install:
cd ${WRKDIR} && \
${INSTALL} -d -o ${WWWOWN} -g ${WWWGRP} ${TOMCATDIR}/webapps/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${WEBAPPDIR}/${PORTDIRNAME}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/deegree_wfs_documentation_en.pdf ${DOCSDIR}