aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/dia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/dia/Makefile')
-rw-r--r--graphics/dia/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index 9c9be2d54833..1dc2dd83d37d 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= dia
-DISTVERSION= 0.96.1
-PORTREVISION= 6
+DISTVERSION= 0.97
PORTEPOCH= 1
CATEGORIES= graphics gnome
MASTER_SITES= GNOME
@@ -25,6 +24,7 @@ USE_GMAKE= yes
USE_GNOME= gtk20 gnomehack gnomeprefix libxslt libartlgpl2 intlhack \
desktopfileutils
WANT_GNOME= yes
+INSTALLS_ICONS= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -32,33 +32,39 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LOCALBASE="${LOCALBASE}"
MAN1= dia.1
+MANLANG= "" fr
.if !defined(WITHOUT_PYTHON)
USE_PYTHON= yes
USE_GNOME+= pygtk2
CONFIGURE_ARGS= --with-python
-PLIST_SUB= PYTHON:=""
+PLIST_SUB+= PYTHON=""
.else
-PLIST_SUB= PYTHON:="@comment "
+PLIST_SUB+= PYTHON="@comment "
.endif
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mlibgnomeui}!=""
USE_GNOME+= libgnomeui
-CONFIGURE_ARGS+= --enable-gnome --enable-bonobo
+INSTALLS_OMF= yes
+CONFIGURE_ARGS+= --enable-gnome
PKGNAMESUFFIX= -gnome
GNOME_ENABLED= yes
+PLIST_SUB+= GNOME=""
.else
-CONFIGURE_ARGS+= --disable-gnome --disable-bonobo
+CONFIGURE_ARGS+= --disable-gnome
+PLIST_SUB+= GNOME="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/lib/intl.c
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
- 's|[(]pkgdatadir[)]/help|(datadir)/gnome/help/dia|g ; \
- s|[(]datadir[)]/help|(datadir)/gnome/help|g'
+.if defined(NOPORTDOCS)
+ @${FIND} ${WRKSRC}/doc -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|$$(examples)||g ; s|$$(mkinstalldirs) $$(sysdoc)/examples||g ; \
+ s|$$(mkinstalldirs) $$(sysdoc)||g'
+.endif
.ifndef (GNOME_ENABLED)
@${FIND} ${WRKSRC} -name Makefile.in | \
${XARGS} ${REINPLACE_CMD} -e \
@@ -72,7 +78,6 @@ pre-configure:
${WRKSRC}/configure
post-install:
- @${INSTALL_DATA} ${WRKSRC}/dia.xpm ${PREFIX}/share/dia/
@-update-desktop-database
.include <bsd.port.post.mk>