aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/exif/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/exif/Makefile')
-rw-r--r--graphics/exif/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/graphics/exif/Makefile b/graphics/exif/Makefile
index dbe9a9bcaf87..88d8b195bc8d 100644
--- a/graphics/exif/Makefile
+++ b/graphics/exif/Makefile
@@ -18,9 +18,17 @@ LIB_DEPENDS= exif.12:${PORTSDIR}/graphics/libexif \
popt.0:${PORTSDIR}/devel/popt
GNU_CONFIGURE= yes
-USE_ICONV= yes
CONFIGURE_ARGS= --with-popt-prefix=${LOCALBASE}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_ICONV= yes
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
MAN1= exif.1
.include <bsd.port.mk>