aboutsummaryrefslogtreecommitdiffstats
path: root/graphics/gimp-app/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gimp-app/Makefile')
-rw-r--r--graphics/gimp-app/Makefile43
1 files changed, 18 insertions, 25 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index e31c449cf70f..3924ad384690 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gimp
-PORTVERSION= 1.1.23
+PORTVERSION= 1.1.24
CATEGORIES= graphics gnome
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/gimp/unstable/v${PORTVERSION}/ \
@@ -15,12 +15,6 @@ MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
MAINTAINER= vanilla@FreeBSD.org
-.if defined(WITH_PERL)
-BUILD_DEPENDS= perldl:${PORTSDIR}/math/PDL \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
-RUN_DEPENDS= perldl:${PORTSDIR}/math/PDL \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
-.endif
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
aa.1:${PORTSDIR}/graphics/aalib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -31,6 +25,7 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+SHLIBVER?= ${PORTVERSION:S/1.//g}
USE_BZIP2= yes
USE_X_PREFIX= yes
@@ -38,10 +33,7 @@ USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-
-.if !defined(WITH_PERL)
-CONFIGURE_ARGS= --disable-perl
-.endif
+PLIST_SUB= SHLIBVER="${SHLIBVER}"
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GLIB_CONFIG="${GLIB_CONFIG}" \
@@ -52,27 +44,28 @@ MAN1= gimp.1 gimptool.1
MAN5= gimprc.5
.if !defined(WITH_PERL)
-PLISTORIG= ${PKGDIR}/PLIST
-PLIST= ${WRKDIR}/PLIST
+CONFIGURE_ARGS= --disable-perl
+PLIST_SUB+= PERL:="@comment "
.else
-PLISTORIG= ${PKGDIR}/PLIST.perl
-PLIST= ${WRKDIR}/PLIST.perl
-.endif
-
-.if !defined(WITH_PERL)
-pre-fetch:
- @${ECHO} -n "If you want to compile with perl support use"
- @${ECHO} "'make -DWITH_PERL' instead"
+BUILD_DEPENDS+= perldl:${PORTSDIR}/math/PDL \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
+RUN_DEPENDS+= perldl:${PORTSDIR}/math/PDL \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
+PLIST_SUB+= PERL:=""
.endif
.if defined(WITH_GNOME) || (exists(${X11BASE}/bin/gnome-config) \
&& !defined(WITHOUT_GNOME))
LIB_DEPENDS+= gtkxmhtml.4:${PORTSDIR}/x11/gnomelibs
-pre-install:
- @${CAT} ${PLISTORIG} > ${PLIST}
+PLIST_SUB+= GNOME:=""
.else
-pre-install:
- @${SED} -e '/helpbrowser/d' ${PLISTORIG} > ${PLIST}
+PLIST_SUB+= GNOME:="@comment "
+.endif
+
+.if !defined(WITH_PERL)
+pre-fetch:
+ @${ECHO} -n "If you want to compile with perl support use "
+ @${ECHO} "'make -DWITH_PERL' instead"
.endif
post-install: